您的位置:首页 > 其它

hdu 1116(并查集+欧拉路径)

2016-05-10 19:23 253 查看

Play on Words

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7080 Accepted Submission(s): 2398


[align=left]Problem Description[/align]
Some
of the secret doors contain a very interesting word puzzle. The team of
archaeologists has to solve it to open that doors. Because there is no
other way to open the doors, the puzzle is very important for us.

There
is a large number of magnetic plates on every door. Every plate has one
word written on it. The plates must be arranged into a sequence in such
a way that every word begins with the same letter as the previous word
ends. For example, the word ``acm'' can be followed by the word
``motorola''. Your task is to write a computer program that will read
the list of words and determine whether it is possible to arrange all of
the plates in a sequence (according to the given rule) and consequently
to open the door.

[align=left]Input[/align]
The
input consists of T test cases. The number of them (T) is given on the
first line of the input file. Each test case begins with a line
containing a single integer number Nthat indicates the number of plates
(1 <= N <= 100000). Then exactly Nlines follow, each containing a
single word. Each word contains at least two and at most 1000 lowercase
characters, that means only letters 'a' through 'z' will appear in the
word. The same word may appear several times in the list.

[align=left]Output[/align]
Your
program has to determine whether it is possible to arrange all the
plates in a sequence such that the first letter of each word is equal to
the last letter of the previous word. All the plates from the list must
be used, each exactly once. The words mentioned several times must be
used that number of times.
If there exists such an ordering of
plates, your program should print the sentence "Ordering is possible.".
Otherwise, output the sentence "The door cannot be opened.".

[align=left]Sample Input[/align]

3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok

[align=left]Sample Output[/align]

The door cannot be opened.
Ordering is possible.
The door cannot be opened.

题意:判断所给的单词能否首尾相连成一串。
题解:1.判断连通分量
   2.判断欧拉路径
详细题解:http://blog.csdn.net/niushuai666/article/details/6917777

#include <stdio.h>
#include <iostream>
#include <string.h>
#include <algorithm>
#include <math.h>
using namespace std;
const int N = 30;
bool vis
; ///判断当前字母是否出现过
int father
;
int indegree
,outdegree
; ///入度和出度
int _find(int x){
if(x==father[x]) return x;
return _find(father[x]);
}
int Union(int a,int b){
int x = _find(a);
int y = _find(b);
if(x==y) return 0;
father[x] = y;
return 1;
}
void init(){
memset(vis,false,sizeof(vis));
memset(indegree,0,sizeof(indegree));
memset(outdegree,0,sizeof(outdegree));
for(int i=0;i<N;i++) father[i]=i;
}
int main()
{
int tcase;
scanf("%d",&tcase);
while(tcase--){
int n;
char str[1005];
scanf("%d",&n);
init();
while(n--){
scanf("%s",str);
int len = strlen(str);
int s = str[0]-'a';
int e = str[len-1]-'a';
Union(s,e);
vis[s] = vis[e] = true;
indegree[e]++;
outdegree[s]++;
}
int ans = 0;
bool flag=false,flag1=false;
int in=0,out=0;
for(int i=0;i<N;i++){
if(vis[i]){
if(father[i]==i) ans++;
if(indegree[i]!=outdegree[i]){
if(indegree[i]-outdegree[i]==1) in++;
else if(outdegree[i]-indegree[i]==1) out++;
else flag1 = true;
}
}
if(ans>1){
flag = true;
}
}
if(!flag&&!flag1&&in==0&&out==0) printf("Ordering is possible.\n");
else if(!flag&&!flag1&&in==1&&out==1) printf("Ordering is possible.\n");
else printf("The door cannot be opened.\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: