您的位置:首页 > 其它

二维树状数组-POJ-2155-Matrix

2016-05-10 18:03 465 查看
Matrix

Time Limit: 3000MS Memory Limit: 65536K

Total Submissions: 23707 Accepted: 8762

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using “not” operation (if it is a ‘0’ then change it into ‘1’ otherwise change it into ‘0’). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.

C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).

Q x y (1 <= x, y <= n) querys A[x, y].

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format “Q x y” or “C x1 y1 x2 y2”, which has been described above.

Output

For each querying output one line, which has an integer representing A[x, y].

There is a blank line between every two continuous test cases.

Sample Input

1

2 10

C 2 1 2 2

Q 2 2

C 2 1 2 1

Q 1 1

C 1 1 2 1

C 1 2 1 2

C 1 1 2 2

Q 1 1

C 1 1 2 1

Q 2 1

Sample Output

1

0

0

1

Source

POJ Monthly,Lou Tiancheng

题意:

给你一个n*n的初始全部为0的矩阵,然后进行t次操作,每次可能有两种操作,一种是让矩阵中一部分全部取非运算,其中(x1,y1)是最左上的点,(x2,y2)是最右下的点;另一种是查询(x,y)的值。

题解:

这是楼教主当年出的题,是经典的二维树状数组,区间修改单点查询的题,注意处理Change时几个矩形的加减法就好。

在这道题做了个测试,关了同步的cin cout还是比scanf printf慢了不少。

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <vector>
#include <set>
#include <utility>
#define LL long long int
using namespace std;
const int MAXN=1005;
int T,n;
LL t,a[MAXN][MAXN];
inline LL LowBit(LL num)
{
return num&(-num);
}
inline void Change(int x,int y,int num)
{
if(x<=0 || y<=0)
return;
for(int i=x;i>0;i-=LowBit(i))
for(int j=y;j>0;j-=LowBit(j))
a[i][j]+=num;
}
inline int GetVaule(int x,int y)
{
LL sum=0;
for(int i=x;i<=n;i+=LowBit(i))
for(int j=y;j<=n;j+=LowBit(j))
sum+=a[i][j];
return sum%2;
}
int main(void)
{
char tmp;
int x1,x2,y1,y2;
scanf("%lld",&T);
while(T--)
{
memset(a,0,sizeof(a));
scanf("%d%lld",&n,&t);
for(LL i=1;i<=t;i++)
{
cin >> tmp;
switch(tmp){
case 'C':   scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
Change(x2,y2,1);Change(x1-1,y1-1,1);Change(x2,y1-1,-1);Change(x1-1,y2,-1);  break;
case 'Q':scanf("%d%d",&x1,&y1); printf("%d\n",GetVaule(x1,y1));
}
}
if(T) printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: