您的位置:首页 > 其它

Beans(dp,两次dp)

2016-05-10 17:41 288 查看

Beans

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 4141 Accepted Submission(s): 1964

[align=left]Problem Description[/align]
Bean-eating is an interesting game, everyone owns an M*N matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 1*1 grid. Now you want to eat the beans and collect the qualities, but everyone must obey by the following rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas are x-1 and x+1.

Now, how much qualities can you eat and then get ?

[align=left]Input[/align]
There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that the quality of bean isn't beyond 1000, and 1<=M*N<=200000.

[align=left]Output[/align]
For each case, you just output the MAX qualities you can eat and then get.

[align=left]Sample Input[/align]

4 6
11 0 7 5 13 9
78 4 81 6 22 4
1 40 9 34 16 10
11 22 0 33 39 6

[align=left]Sample Output[/align]

242

题解:一次对行dp,一次对列dp;

java超时了。。。c就不会

代码:

import java.util.Scanner;

public class Beans {
static int a[] = new int[200010], dp[] = new int[200010], DP[] = new int[200010], b[] = new int[200010];
public static void main(String[] argvs){
int M, N;
Scanner cin = new Scanner(System.in);
while(cin.hasNext()){
M = cin.nextInt();
N = cin.nextInt();
for(int i = 0; i < M; i++){
DP[i] = 0;
for(int j = 0; j < N; j++){
dp[j] = 0;
a[j] = cin.nextInt();
if(j < 2)
dp[j] = a[j];
else
dp[j] = Math.max(dp[j - 2] + a[j], dp[j - 1]);
}
DP[i] = dp[N - 1];
if(i < 2)
b[i] = DP[i];
else
b[i] = Math.max(b[i - 2] + DP[i], b[i - 1]);
}
System.out.println(b[M - 1]);
}

}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: