您的位置:首页 > 其它

ZOJ 3870:Team Formation【技巧】

2016-05-10 16:23 489 查看
Team Formation
Time Limit: 3 Seconds      Memory Limit: 131072 KB
For an upcoming programming contest, Edward, the headmaster of Marjar University, is forming a two-man team from N students of his university.
Edward knows the skill level of each student. He has found that if two students with skill level A and B form a team, the skill level of the team will be A ⊕ B,
where ⊕ means bitwise exclusive or. A team will play well if and only if the skill level of the team is greater than the skill level of each team member (i.e. A ⊕ B > max{A, B}).
Edward wants to form a team that will play well in the contest. Please tell him the possible number of such teams. Two teams are considered different if there is at least one different
team member.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:
The first line contains an integer N (2 <= N <= 100000), which indicates the number of student. The next line contains N positive integers separated by
spaces. The ith integer denotes the skill level of ith student. Every integer will not exceed 109.

Output

For each case, print the answer in one line.

Sample Input

2
3
1 2 3
5
1 2 3 4 5

Sample Output

1
6

思路:
对于一个数,如果我们把x的二进制表示中最高位的0变成1,0前面的都不变,那么得到的这个新值肯定比x大。即:如果x的第i位为1(i为x的最高位的1所在位置),y的第i位为0(i不是y的最高位所在位置),那么z=x^y之后,z > max(x, y)。
AC-code:
#include<cstdio>
#include<cstring>
using namespace std;
int b[32];
int a[100005];
void check(int x)
{
int l=31;
while(l>=0)
{
if(x&(1<<l))
{
b[l]++;
return ;
}
l--;
}
}
int main()
{
int T,n,i;
long long sum;
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
memset(b,0,sizeof(b));
for(i=0;i<n;i++)
{
scanf("%d",&a[i]);
check(a[i]);
}
sum=0;
for(i=0;i<n;i++)
{
int l=31;
while(l>=0)
{
if(a[i]&(1<<l))
break;
l--;
}
while(l>=0)
{
if(!(a[i]&(1<<l)))
{
sum+=b[l];
}
l--;
}
}
printf("%lld\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: