您的位置:首页 > 其它

CodeForces - 670D1 Magic Powder - 1 (模拟)

2016-05-10 12:59 423 查看
CodeForces - 670D1

Magic Powder - 1

Time Limit: 1000MS Memory Limit: 262144KB 64bit IO Format: %I64d & %I64u
Submit

Status

Description

This problem is given in two versions that differ only by constraints. If you can solve this problem in large constraints, then you can just write a single solution to the both versions. If you find the problem too difficult
in large constraints, you can write solution to the simplified version only.

Waking up in the morning, Apollinaria decided to bake cookies. To bake one cookie, she needs
n ingredients, and for each ingredient she knows the value
ai — how many grams of this ingredient one needs to bake a cookie. To prepare one cookie Apollinaria needs to use all
n ingredients.

Apollinaria has bi gram of the
i-th ingredient. Also she has
k grams of a magic powder. Each gram of magic powder can be turned to exactly
1 gram of any of the n ingredients and can be used for baking cookies.

Your task is to determine the maximum number of cookies, which Apollinaria is able to bake using the ingredients that she has and the magic powder.

Input

The first line of the input contains two positive integers
n and k (1 ≤ n, k ≤ 1000) — the number of ingredients and the number of grams of the magic powder.

The second line contains the sequence a1, a2, ..., an (1 ≤ ai ≤ 1000),
where the i-th number is equal to the number of grams of the
i-th ingredient, needed to bake one cookie.

The third line contains the sequence b1, b2, ..., bn (1 ≤ bi ≤ 1000),
where the i-th number is equal to the number of grams of the
i-th ingredient, which Apollinaria has.

Output

Print the maximum number of cookies, which Apollinaria will be able to bake using the ingredients that she has and the magic powder.

Sample Input

Input
3 1
2 1 4
11 3 16


Output
4


Input
4 3
4 3 5 6
11 12 14 20


Output
3


Sample Output

Hint

Source
Codeforces Round #350 (Div. 2)
//题意:输入n,m;  m表示的事魔法元素的数量,每个魔法元素可以转变成任意一个其他的元素;
表示制作饼干需要n种元素,并且制作一个饼干所需的每种元素的的数量是a[i],现在给你每种元素的数量b[i],问你最多可以制作几个饼干?
//思路:
因为n是1000,所以直接模拟,最多是1000*1000;
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#define INF 0x3f3f3f3f
#define N 1010
using namespace std;
int a
,b
;
struct zz
{
int a;
int b;
int c;
}p
;
int main()
{
int n,k,i;
while(scanf("%d%d",&n,&k)!=EOF)
{
int sum=0;
for(i=0;i<n;i++)
scanf("%d",&a[i]);
for(i=0;i<n;i++)
scanf("%d",&b[i]);
int mm=INF;
for(i=0;i<n;i++)
{
p[i].a=b[i]/a[i];
p[i].b=b[i]%a[i];
p[i].c=a[i]-p[i].b;
mm=min(mm,p[i].a);
}
while(1)
{
for(i=0;i<n;i++)
{
if(p[i].a==mm)
{
if(k<p[i].c)
break;
else
{
k-=p[i].c;
p[i].c=a[i];
p[i].a=mm+1;
}
}
}
if(i==n)
mm++;
else
break;
}
printf("%d\n",mm);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: