您的位置:首页 > 其它

hduoj 1024 Max Sum Plus Plus(最大m子段和)

2016-05-10 00:34 260 查看

Max Sum Plus Plus

[align=center]Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24192    Accepted Submission(s): 8289

[/align]

[align=left]Problem Description[/align]

Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S1, S2, S3, S4 ... Sx, ... Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define
a function sum(i, j) = Si + ... + Sj (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + ... + sum(im,
jm) maximal (ix ≤ iy ≤ jx or ix ≤ jy ≤ jx is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead. ^_^

 

[align=left]Input[/align]

Each test case will begin with two integers m and n, followed by n integers S1, S2, S3 ... Sn.

Process to the end of file.

 

[align=left]Output[/align]

Output the maximal summation described above in one line.

 

[align=left]Sample Input[/align]

1 3 1 2 3
2 6 -1 4 -2 3 -2 3

 

[align=left]Sample Output[/align]
6
8
#include <iostream>
#include <algorithm>
#include <map>
#include <cstdio>
#include <string>
#include <cstring>
using namespace std;
int s[1000005];
int dp[1000005];
int temp[1000005];
void DP(int m , int n){
int i , j , k;
int max;
memset(dp , 0 ,sizeof(dp));
memset(temp , 0 , sizeof(temp));
for(i = 1 ; i <= m ; i++){//用以个for循环遍历
max = -999999999;//注意这里的max要为无穷小,分别在求i子段最大和时候进行初始化
for(j = i ; j <= n ; j++){
dp[j] = (dp[j-1] + s[j]) > (temp[j-1] + s[j])?(dp[j-1] + s[j]) : (temp[j-1] + s[j]);
temp[j-1] = max;//这里的temp[j-1]用来存储前面j-1的元素i子段最大值,注意不是temp[j]因为还没判 断是否max<dp[j];
if(max < dp[j])
max = dp[j];//更新max
}
}
cout<<max<<endl;
}
int main(){
int i , j;
int n , m;
while(scanf("%d%d" , &m , &n) != EOF){
for(i = 1 ; i <= n ; i++)
scanf("%d" , &s[i]);
DP(m , n);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: