您的位置:首页 > 其它

A - Rooks

2016-05-09 17:39 344 查看
http://acm.hust.edu.cn/vjudge/contest/view.action?cid=29041#problem/A

简单组合数

A - Rooks
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu
Submit Status Practice LightOJ
1005

Description

A rook is a piece used in the game of chess which is played on a board of square grids. A rook can only move vertically or horizontally from its current position and two rooks attack each other if one is on the path of the other. In the following figure,
the dark squares represent the reachable locations for rook R1 from its current position. The figure also shows that the rook R1 and R2 are in attacking positions where R1 and R3 are
not. R2 and R3are also in non-attacking positions.



Now, given two numbers n and k, your job is to determine the number of ways one can put k rooks on an n x nchessboard so that no two of them are in attacking positions.

Input

Input starts with an integer T (≤ 350), denoting the number of test cases.

Each case contains two integers n (1 ≤ n ≤ 30) and k (0 ≤ k ≤ n2).

Output

For each case, print the case number and total number of ways one can put the given number of rooks on a chessboard of the given size so that no two of them are in attacking positions. You may safely assume that this number will be less than 1017.

Sample Input

8

1 1

2 1

3 1

4 1

4 2

4 3

4 4

4 5

Sample Output

Case 1: 1

Case 2: 4

Case 3: 9

Case 4: 16

Case 5: 72

Case 6: 96

Case 7: 24

Case 8: 0

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
#define LL long long
using namespace std;
const int maxn=1<<30;
const int SIZE=1e2+10;
unsigned LL C[40][40];
void get_(){
for(int i=0;i<=30;i++)
C[i][0]=C[i][i]=1;
for(int i=2;i<=30;i++){
for(int j=1;j<i;j++){
C[i][j]=C[i-1][j-1]+C[i-1][j];
}
}
}
int main()
{
int T,n,k;
get_();
4000

scanf("%d",&T);
for(int cas=1;cas<=T;cas++){
scanf("%d%d",&n,&k);
unsigned LL ans=C
[k];
for(int i=n;i>n-k;i--){
ans*=i;
}
printf("Case %d: %llu\n",cas,ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: