您的位置:首页 > 其它

Pku oj 2485 Highways(MST)

2016-05-09 17:19 369 查看
Highways

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 27506Accepted: 12562
Description
The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They're planning to build some highways
so that it will be possible to drive between any pair of towns without leaving the highway system.

Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town
that is located at the end of both highways.

The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.
Input
The first line of input is an integer T, which tells how many test cases followed.

The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between
village i and village j. There is an empty line after each test case.
Output
For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.
Sample Input
1

3
0 990 692
990 0 179
692 179 0

Sample Output
692

Hint
Huge input,scanf is recommended.
Source
POJ Contest,Author:Mathematica@ZSU

读完题之后就会发现本质是求最小生成树中边最大权值,因为题中给的是邻接矩阵中的存图方法,所以我用Prim算法实现MST,加一个Max初始化为-1,每次往MST加入边的时候与Max比较就可以

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;

const int maxn = 505;
const int Inf = 0x3f3f3f;
int map[maxn][maxn];
int dis[maxn];
int vis[maxn];
int n,m;
int t;

void init()
{
for(int i=0;i<n;i++)
{
dis[i] = map[i][0];
vis[i] = 0;
}
}

int prim()
{
init();
dis[0] = 0;
vis[0] = 1;
int ans = 0;
int max = -1;
for(int i=0;i<n-1;i++)
{
int min = Inf;
int temp;
for(int j=0;j<n;j++)
{
if(!vis[j] && dis[j] < min)
{
temp = j;
min = dis[j];
}
}
vis[temp] = 1;
ans += dis[temp];
if(dis[temp] > max)
max = dis[temp];
for(int j=0;j<n;j++)
{
if(!vis[j] && dis[j] > map[temp][j])
dis[j] = map[temp][j];
}
}
return max;
}

int main()
{
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
for(int i=0;i<n;i++)
{
for(int j=0;j<n;j++)
scanf("%d",&map[i][j]);
}
int ans = prim();
printf("%d\n",ans);
}
return 0;
}

/*
1
3
0 990 692990 0 179
692 179 0
*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: