您的位置:首页 > 其它

nyoj5 Binary String Matching(KMP)

2016-05-09 15:28 267 查看

Binary String Matching

时间限制:3000 ms | 内存限制:65535 KB

难度:3

描述 Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because
the pattern A appeared at the posit

输入The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always
longer than A.输出For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.样例输入
3
11
1001110110
101
110010010010001
1010
110100010101011

样例输出
3
0
3


题意:求出主串中模式串出现的次数.

朴素算法code:

#include <cstdio>
#include <cstring>
int main()
{
int n,count;
char a[200],b[1200];
scanf("%d",&n);
getchar();
while(n--)
{
count=0;
int i=0,j=0,len;
scanf("%s\n%s",a,b);
len=strlen(b);
while(i<=len)
{
if(a[j]=='\0')
{
count++;
i=i-j+1;
j=0;
}
else if(a[j]==b[i])
{
i++;
j++;
}
else
{
i=i-j+1; //关键在于回溯
j=0;
}
}
printf("%d\n",count);
}
return 0;
}


KMP算法:
#include<cstdio>
#include<cstring>
int nextval[200];
void get_next(char a[])//得到next数组;
{
int len;
int i=0,j=-1;
nextval[0]=-1;
len=strlen(a);
while(i<=len)
{
if(j==-1 || a[i]==a[j])
{
++i;
++j;
if(a[i]==a[j])
nextval[i] = nextval[j];  //把回溯的内容全换成是next数组;
else
nextval[i] = j;
}
else
j=nextval[j];
}
}
int kmp(char a[],char b[])//kmp的主体函数
{
int i=0,j=0,count=0;
int lena,lenb;
lena=strlen(a);
lenb=strlen(b);
get_next(a);
while(i<=lenb)
{
if(j==-1 || a[j]==b[i])
{
++i;
++j;
}
else
j=nextval[j];
if(j>=lena)
{
count++;
j=nextval[j];
}
}
return count;
}
int main()
{
int n;
char a[20],b[1200];
scanf("%d",&n);
while(n--)
{
scanf("%s\n%s",a,b);
printf("%d\n",kmp(a,b));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: