您的位置:首页 > 其它

hdu 2795 Billboard(线段树)

2016-05-08 14:40 218 查看
问题描述

At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes
in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.

 

输入

There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.

 

输出

For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't
be put on the billboard, output "-1" for this announcement.
 

样例输入

 3 5 5
2
4
3
3
3

 

样例输出

 1
2
1
3
-1

把每一行都当成一个节点,比如第一行就是(1,1)这个点,第i行就用(i,i)表示,其中的值就是剩余可以贴海报的长度。

需要注意的是因为海波数量n最大可取200000,所以即便是海报一个一行,最多也就200000行,所以线段树只需开4*200000即可。

#include <iostream>
#include <stdio.h>
using namespace std;

const int MAXX=200005;

int w,h,n,ans;

struct node
{
int x,y,k;
}no[4*MAXX];

void build(int rt,int l,int r)
{
int mid=(l+r)>>1;

no[rt].x=l;
no[rt].y=r;
no[rt].k=w;
if(l==r)
return ;
build(rt<<1,l,mid);
build(rt<<1|1,mid+1,r);
}

void updata(int rt,int k)
{
if(no[rt].x==no[rt].y)
{
no[rt].k-=k;
ans= no[rt].x;
return ;
}
else
{
if(no[rt<<1].k>=k)
updata(rt<<1,k);
else
updata(rt<<1|1,k);
}
no[rt].k=max(no[rt<<1].k,no[rt<<1|1].k);
return ;
}

int main()
{
while(scanf("%d%d%d",&h,&w,&n)!=EOF)
{
if(h>MAXX)
h=MAXX;
build(1,1,h);
for(int i=0;i<n;i++)
{
int ka;
ans=0;
scanf("%d",&ka);
if(no[1].k<ka)
printf("-1\n");
else
{updata(1,ka);
printf("%d\n",ans);

}

}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: