您的位置:首页 > 其它

HDU 3006 The Number of set

2016-05-07 19:56 549 查看
Problem Description

Given you n sets.All positive integers in sets are not less than 1 and not greater than m.If use these sets to combinate the new set,how many different new set you can get.The given sets can not be broken.

 

Input

There are several cases.For each case,the first line contains two positive integer n and m(1<=n<=100,1<=m<=14).Then the following n lines describe the n sets.These lines each contains k+1 positive integer,the first which is k,then k integers are given. The
input is end by EOF.

 

Output

For each case,the output contain only one integer,the number of the different sets you get.

 

Sample Input

4 4
1 1
1 2
1 3
1 4
2 4
3 1 2 3
4 1 2 3 4

 

Sample Output

15
2
简单状态压缩dp
#include<cmath>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
const double pi = acos(-1.0);
const int low(int x) { return x&-x; }
const int INF = 0x7FFFFFFF;
const int mod = 1e9 + 7;
const int maxn = 1e5 + 10;
int n, m, x, y, z;
int dp[maxn];

int main()
{
while (scanf("%d%d", &n, &m) != EOF)
{
for (int i = dp[0] = 1; i < (1 << m); i++) dp[i] = 0;
while (n--)
{
scanf("%d", &x);	z = 0;
while (x--) { scanf("%d", &y); z |= 1 << y - 1; }
for (int i = 0; i < (1 << m); i++) dp[i | z] = dp[i] | dp[i | z];
}
int ans = 0;
for (int i = 1; i < (1 << m); i++) ans += dp[i];
printf("%d\n", ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  HDU