您的位置:首页 > 其它

POJ-1459 Power Network (最大流[Ford-Fulkerson])

2016-05-07 16:44 375 查看
Power Network
http://poj.org/problem?id=1459

Time Limit: 2000MSMemory Limit: 32768K
Description

A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= pmax(u) of power, may consume an amount
0 <= c(u) <= min(s(u),cmax(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power
transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= lmax(u,v) of power delivered by u to v. Let Con=Σuc(u) be the power consumed in the net. The problem is to compute the maximum value of
Con.



An example is in figure 1. The label x/y of power station u shows that p(u)=x and pmax(u)=y. The label x/y of consumer u shows that c(u)=x and cmax(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and lmax(u,v)=y.
The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6.

Input

There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets
(u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of lmax(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of pmax(u). The data set
ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of cmax(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can
occur freely in input. Input data terminate with an end of file and are correct.
Output

For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.
Sample Input
2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
(3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
(0)5 (1)2 (3)2 (4)1 (5)4

Sample Output
15
6

Hint

The sample input contains two data sets. The first data set encodes a network with 2 nodes, power station 0 with pmax(0)=15 and consumer 1 with cmax(1)=20, and 2 power transport lines with lmax(0,1)=20 and lmax(1,0)=10. The maximum value of Con is 15. The second
data set encodes the network from figure 1.

题目大意:给定np个生产者,nc个消费者,m条能量转移的边,求最多能消耗的能量?

添加一个虚拟源点和一个虚拟汇点,添加源点到生产者的边(权值为生产者能生产的能量),添加消费者到汇点的边(权值为消费者能消费的能量),则转化为最大流模版题。

刚开始用STL库的queue和priority_queue,结果都超时了,第一次被STL的慢坑住了。。。换成数组模拟的队列800ms AC

#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>

using namespace std;

const int MAXN=105;
const int INF=0x3f3f3f3f;

struct Node {
int pre,u,mn;//u表示当前节点,mn表示从源点到该点的流量上限中最小的
}cur,q[MAXN*MAXN];

int n,np,nc,m,s,e,l,STA,DES,head,tail;
int g[MAXN][MAXN],pre[MAXN];
bool vis[MAXN];

int bfs(int sta,int des) {//用bfs找到流量最大的一条增广路径,并返回这条增广路径的流量
memset(vis,false,sizeof(vis));
head=tail=0;
q[tail].pre=-1;
q[tail].u=sta;
q[tail++].mn=INF;

while(head!=tail) {
do {
cur=q[head++];
}while(head!=tail&&vis[cur.u]);
if(vis[cur.u]) {//如果无法到达汇点,则返回0
return 0;
}

vis[cur.u]=true;
pre[cur.u]=cur.pre;
if(cur.u==des) {
return cur.mn;
}
for(int i=0;i<=n;++i) {//枚举可流向的下一个点
if(!vis[i]&&g[cur.u][i]!=0) {
q[tail].pre=cur.u;
q[tail].u=i;
q[tail++].mn=min(cur.mn,g[cur.u][i]);
}
}
}
return 0;
}

int Ford_Fulkerson(int sta,int des) {//当可增加的流量不为0时,继续算法
int mn,e,ans=0;
while(mn=bfs(sta,des),mn!=0) {
ans+=mn;
e=des;
while(e!=sta) {
g[pre[e]][e]-=mn;//正向的边减去相应的流量
g[e][pre[e]]+=mn;//反向的边加上相应的流量
e=pre[e];
}
}
return ans;
}

int main() {
while(4==scanf("%d%d%d%d",&n,&np,&nc,&m)) {
STA=n;
DES=++n;
memset(g,0,sizeof(g));
for(int i=0;i<m;++i) {
scanf(" (%d,%d)%d",&s,&e,&l);
g[s][e]+=l;
}
for(int i=0;i<np;++i) {
scanf(" (%d)%d",&e,&l);
g[STA][e]+=l;
}
for(int i=0;i<nc;++i) {
scanf(" (%d)%d",&s,&l);
g[s][DES]+=l;
}
printf("%d\n",Ford_Fulkerson(STA,DES));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: