您的位置:首页 > 其它

第六届山东省ACM竞赛 J题 Single Round Math

2016-05-07 14:33 330 查看


Single Round Math



Time Limit: 1000MS Memory limit: 65536K


题目描述

Association for Couples Math (ACM) is a non-profit organization which is engaged in helping single people to find his/her other half. As November 11th is “Single Day”, on this day, ACM invites a large group of singles to
the party. People round together, chatting with others, and matching partners.
There are N gentlemen and M ladies in the party, each gentleman should only match with a lady and vice versa. To memorize the Singles Day, ACM decides to divides to divide people into 11 groups, each group should have the
same amount of couples and no people are left without the groups.
Can ACM achieve the goal?


输入

The first line of the input is a positive integer T. T is the number of test cases followed. Each test case contains two integer N and M (0 ≤ N, M ≤ 101000), which are the amount of gentlemen and ladies.


输出

For each test case, output “YES” if it is possible to find a way, output “NO” if not.


示例输入

3
1 1
11 11
22 11



示例输出

NO
YES
NO



Java解决大数问题真是好用

import java.math.BigInteger;
import java.util.Scanner;

public class Main{

public static void main(String[] args) {
int t;
BigInteger n = null, m = null;
BigInteger MOD = new BigInteger("11");
BigInteger ZERO = new BigInteger("0");
Scanner in = new Scanner(System.in);
t = in.nextInt();
for (int i = 0; i < t; i++) {
n = in.nextBigInteger();
m = in.nextBigInteger();
if (n.compareTo(m) == 0 && n.mod(MOD).compareTo(ZERO) == 0){
System.out.println("YES");
}
else{
System.out.println("NO");
}
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: