您的位置:首页 > 其它

第六届山东省ACM竞赛 C题 Game!

2016-05-07 14:30 232 查看

Game!

Time Limit: 1000MS Memory limit: 65536K

题目描述

One day, zbybr is playing a game with blankcqk, here are the rules of the game:

There is a circle of N stones, zbybr and blankcqk take turns taking the stones.

Each time, one player can choose to take one stone or take two adjacent stones.

You should notice that if there are 4 stones, and zbybr takes the 2nd, the 1st and 3rd stones are still not adjacent.

The winner is the one who takes the last stone.

Now, the game begins and zbybr moves first.

If both of them will play with the best strategy, can you tell me who will win the game?

输入

The first line of input contains an integer T, indicating the number of test cases (T≈100000).
For each case, there is a positive integer N (N ≤ 1018).

输出

Output the name of the winner.

示例输入

2

1

2


示例输出

zbybr

zbybr




简单博弈,同poj2484
#include <cstdio>
using namespace std;
typedef long long ll;

int t;
ll n;
int main()
{
scanf("%d", &t);
while (t--){
scanf("%lld", &n);
if (n <= 2){
printf("zbybr\n");
}
else
printf("blankcqk\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: