您的位置:首页 > 大数据 > 人工智能

【模拟】HDU1302The Snail

2016-05-07 14:01 555 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1302

Problem Description

A snail is at the bottom of a 6-foot well and wants to climb to the top. The snail can climb 3 feet while the sun is up, but slides down 1 foot at night while sleeping. The snail has a fatigue factor of 10%, which means that on each successive day the snail
climbs 10% * 3 = 0.3 feet less than it did the previous day. (The distance lost to fatigue is always 10% of the first day's climbing distance.) On what day does the snail leave the well, i.e., what is the first day during which the snail's height exceeds 6
feet? (A day consists of a period of sunlight followed by a period of darkness.) As you can see from the following table, the snail leaves the well during the third day. 

Day Initial Height Distance Climbed Height After Climbing Height After Sliding 

1 0 3 3 2 

2 2 2.7 4.7 3.7 

3 3.7 2.4 6.1 - 

Your job is to solve this problem in general. Depending on the parameters of the problem, the snail will eventually either leave the well or slide back to the bottom of the well. (In other words, the snail's height will exceed the height of the well or become
negative.) You must find out which happens first and on what day.

 

Input

The input file contains one or more test cases, each on a line by itself. Each line contains four integers H, U, D, and F, separated by a single space. If H = 0 it signals the end of the input; otherwise, all four numbers will be between 1 and 100, inclusive.
H is the height of the well in feet, U is the distance in feet that the snail can climb during the day, D is the distance in feet that the snail slides down during the night, and F is the fatigue factor expressed as a percentage. The snail never climbs a negative
distance. If the fatigue factor drops the snail's climbing distance below zero, the snail does not climb at all that day. Regardless of how far the snail climbed, it always slides D feet at night.

 

Output

For each test case, output a line indicating whether the snail succeeded (left the well) or failed (slid back to the bottom) and on what day. Format the output exactly as shown in the example.

 

Sample Input

6 3 1 10
10 2 1 50
50 5 3 14
50 6 4 1
50 6 3 1
1 1 1 1
0 0 0 0

 

Sample Output

success on day 3
failure on day 4
failure on day 7
failure on day 68
success on day 20
failure on day 2

题目意思:

这个题目就是考你看英文题。。。我竟然咬着牙看懂了题目意思。

给你4个数h,u,d,f 分别表示墙的高度,白天能爬的高度,晚上掉下来的高度,以及疲劳比

例如第一组数据 6 3 1 10,

      天数   起始  当天爬的高度    爬完之后的高度  晚上掉下来之后的高度

1 0
3 3

2 2
2.7 4.7
3.7 
3 3.7
2.4 6.1


代码:

#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
cin.sync_with_stdio(false);
double h,u,d,f;
while(cin>>h>>u>>d>>f){
double st=0;
int flag=0;
if(h==0)break;
int cnt=0;
while(1){
st+=1.0*u-0.01*f*u*cnt;
cnt++;
//printf("%.2lf\n",st);
if(st>h){
flag=1;
break;
}
st-=d;
if(st<0) break;
}
if(flag) cout<<"success on day ";
else cout<<"failure on day ";
cout<<cnt<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: