您的位置:首页 > 其它

POJ 1655 Balancing Act

2016-05-07 13:43 239 查看
Description

Consider a tree T with N (1 <= N <= 20,000) nodes numbered 1...N. Deleting any node from the tree yields a forest: a collection of one or more trees. Define the balance of a node to be the size of the largest tree in the forest T created by deleting that node
from T. 

For example, consider the tree: 



Deleting node 4 yields two trees whose member nodes are {5} and {1,2,3,6,7}. The larger of these two trees has five nodes, thus the balance of node 4 is five. Deleting node 1 yields a forest of three trees of equal size: {2,6}, {3,7}, and {4,5}. Each of these
trees has two nodes, so the balance of node 1 is two. 

For each input tree, calculate the node that has the minimum balance. If multiple nodes have equal balance, output the one with the lowest number. 

Input

The first line of input contains a single integer t (1 <= t <= 20), the number of test cases. The first line of each test case contains an integer N (1 <= N <= 20,000), the number of congruence. The next N-1 lines each contains two space-separated node numbers
that are the endpoints of an edge in the tree. No edge will be listed twice, and all edges will be listed.

Output

For each test case, print a line containing two integers, the number of the node with minimum balance and the balance of that node.

Sample Input

1
7
2 6
1 2
1 4
4 5
3 7
3 1


Sample Output

1 2


Source

POJ Monthly--2004.05.15 IOI 2003
sample task

找树的重心。
#include<cmath>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
const double pi = acos(-1.0);
const int low(int x) { return x&-x; }
const int INF = 0x7FFFFFFF;
const int mod = 1e9 + 7;
const int maxn = 1e5 + 10;
int T, n, x, y;
int ft[maxn], nt[maxn], u[maxn], sz;
int cnt[maxn], mx[maxn];

void AddEdge(int x, int y)
{
u[sz] = y; nt[sz] = ft[x]; ft[x] = sz++;
}

int dfs(int x, int fa, int sum)
{
int ans = 0;
cnt[x] = 1; mx[x] = 0;
for (int i = ft[x]; i != -1; i = nt[i])
{
if (u[i] == fa) continue;
int y = dfs(u[i], x, sum);
cnt[x] += cnt[u[i]];
mx[x] = max(mx[x], cnt[u[i]]);
if (mx[y] < mx[ans]) ans = y;
else if (mx[y] == mx[ans]) ans = min(ans, y);
}
mx[x] = max(mx[x], sum - cnt[x]);
if (mx[x] < mx[ans]) ans = x;
else if (mx[x] == mx[ans]) ans = min(ans, x);
return ans;
}

int main()
{
scanf("%d", &T);
while (T--)
{
scanf("%d", &n);
mx[sz = 0] = INF;
for (int i = 1; i <= n; i++) ft[i] = -1;
for (int i = 1; i < n; i++)
{
scanf("%d%d", &x, &y);
AddEdge(x, y);
AddEdge(y, x);
}
int rt = dfs(1, -1, n);
printf("%d %d\n", rt, mx[rt]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj