您的位置:首页 > 其它

Problem B

2016-05-06 22:04 155 查看
[align=left]Problem Description[/align]
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a
strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences
X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. <br>The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number
of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. <br>
 

[align=left]Sample Input[/align]

abcfbc abfcab
programming contest
abcd mnp

 

[align=left]Sample Output[/align]

4
2
0

 
简单题意:

  现在给出两个序列X、Y,要求编写一个程序,求出这两个序列最长的公共上升子序列。

解题思路形成过程:

  这和课上给出的例题本质是一样的。属于动态规划的经典入门题目。运用动态规划的思想,排除重复计算,得到最后的结果。

感想:

  就只把课本上的例题吃透、想明白,也是对自己能力的一种很大的提高。

AC代码:

#include <iostream>

#include <cstdio>

#include <cstring>

#include <algorithm>

using namespace std;

char s1[1000],s2[1000];

int dp[1000][1000];

int len1,len2;

void LCS()

{

    int i,j;

    memset(dp,0,sizeof(dp));

    for(i = 1; i<=len1; i++)

    {

        for(j = 1; j<=len2; j++)

        {

            if(s1[i-1] == s2[j-1])

                dp[i][j] = dp[i-1][j-1]+1;

            else

                dp[i][j] = max(dp[i-1][j],dp[i][j-1]);

        }

    }

}

int main()

{

    while(~scanf("%s%s",s1,s2))

    {

        len1 = strlen(s1);

        len2 = strlen(s2);

        LCS();

        printf("%d\n",dp[len1][len2]);

    }

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm