您的位置:首页 > 理论基础 > 计算机网络

hdu1532——Drainage Ditches(网络流模板)

2016-05-06 20:14 603 查看
Problem Description

Every time it rains on Farmer John’s fields, a pond forms over Bessie’s favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie’s clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.

Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.

Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond.

Sample Input

5 4

1 2 40

1 4 20

2 4 20

2 3 30

3 4 10

Sample Output

50

模板题,拿来初学网络流。就是不断找增广路径来增加流量

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <queue>
#include <vector>
#include <iostream>
#include <set>
#include <cstring>
#include <string>
#define MAXN 510
#define inf 0x3f3f3f3f
using namespace std;
struct Node
{
int to,cap,rev;  //终点、容量、反向边
};
vector<Node> v[MAXN];
bool vis[MAXN];
void add(int from,int to,int cap)
{
v[from].push_back((Node){to,cap,v[to].size()});
v[to].push_back((Node){from,0,v[from].size()-1});
}
int dfs(int s,int t,int f)
{
if(s==t)
return f;
vis[s]=true;
for(int i=0;i<v[s].size();++i)
{
Node &tmp=v[s][i];
if(!vis[tmp.to]&&tmp.cap>0)
{
int d=dfs(tmp.to,t,min(f,tmp.cap));  //找增广路径,可以增加的量为这个路径上残余量最少的
if(d>0)  //有可增广的量,修改流量
{
tmp.cap-=d;
v[tmp.to][tmp.rev].cap+=d; //反向边的修改
return d;
}
}
}
return 0;
}
int max_flow(int s,int t)
{
int flow=0;
while(1)  //一直找增光路径直到不能再增加
{
memset(vis,false,sizeof(vis));
int f=dfs(s,t,inf);
if(f==0)
return flow;
flow+=f;
}
}
int main()
{
int n,m;
while(~scanf("%d%d",&n,&m))
{
memset(v,0,sizeof(v));
for(int i=0;i<n;++i)
{
int x,y,z;
scanf("%d%d%d",&x,&y,&z);
add(x,y,z);
}
printf("%d\n",max_flow(1,m));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: