您的位置:首页 > 其它

HDUOJ 1062 Text Reverse

2016-05-06 20:14 218 查看
Problem Description

Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains a single line with several words. There will be at most 1000 characters in a line.

Output

For each test case, you should output the text which is processed.

Sample Input

3
olleh !dlrow
m'I morf .udh
I ekil .mca


Sample Output

hello world!
I'm from hdu.
I like acm.

Hint
Remember to use getchar() to read '\n' after the interger T, then you may use gets() to read a line and process it.


AC代码:

#include<stdio.h>
int main()
{
int n,i,j,k;
char a[1005],b[1005];
scanf("%d",&n);
getchar();
while(n--)
{
k=0;
gets(a);
for(i=0; a[i]!='\0'; i++)
{
if(a[i]!=' '&&(a[i+1]==' '||a[i+1]=='\0'))
{
if(k==0)
for(j=i; j>=0; j--)
b[k++]=a[j];
else
for(j=i; a[j]!=' '; j--)
b[k++]=a[j];
}
if(a[i]==' ')
b[k++]=' ';
}
for(i=0; i<k; i++)
printf("%c",b[i]);
printf("\n");
}
return 0;
}


Problem Description

Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains a single line with several words. There will be at most 1000 characters in a line.

Output

For each test case, you should output the text which is processed.

Sample Input

3
olleh !dlrow
m'I morf .udh
I ekil .mca


Sample Output

hello world!
I'm from hdu.
I like acm.

Hint
Remember to use getchar() to read '\n' after the interger T, then you may use gets() to read a line and process it.
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: