您的位置:首页 > 其它

NYOJ 715 Adjacent Bit Counts

2016-05-06 13:59 260 查看



Adjacent Bit Counts

时间限制:1000 ms | 内存限制:65535 KB
难度:4

描述

For a string of n bits x1, x2, x3, …, xn, the adjacent bit count of the string is given by fun(x) = x1*x2 + x2*x3 + x3*x 4 +
… + xn-1*x n

which counts the number of times a 1 bit is adjacent to another 1 bit. For example:

Fun(011101101) = 3

Fun(111101101) = 4

Fun (010101010) = 0
Write a program which takes as input integers n and p and
returns the number of bit strings x of n bits (out of 2ⁿ) that satisfy Fun(x) = p.

For example, for 5 bit strings, there are 6 ways of getting fun(x) = 2:

11100, 01110, 00111, 10111, 11101, 11011

输入On the first line of the input is a single positive integer k, telling the number of test cases to follow. 1 ≤ k ≤ 10 Each case is a single line that contains a decimal integer giving the number (n) of bits in the bit strings,
followed by a single space, followed by a decimal integer (p) giving the desired adjacent bit count. 1 ≤ n , p ≤ 100
输出For each test case, output a line with the number of n-bit strings with adjacent bit count equal to p.
样例输入
2
5 2
20 8


样例输出
6
63426


来源第六届河南省程序设计大赛
上传者ACM_赵铭浩

动态规划,表示公式看半天都没看懂,但确实有这么个规律。dp[i][j][0 or 1] ,其中i表示二进制的位数,j 表示 fun(x)的值,最后的 0 or 1 表示该二进制数的最后一位是0 还是 1。dp[i][j][0] = dp[i - 1][j][0] + dp[i - 1][j][1]; j = 0时, dp[i][j][1] = dp[i - 1][j][0];j > 0时,dp[i][j][1] = dp[i - 1][j][0] +
dp[i - 1][j][0] 。最后的结果就应该是最后一位是0和1的种数之和。

#include<stdio.h>
#include<string.h>
long long int dp[110][110][2];
//dp[i][j][0]表示fun值为j的i位二进制数的最后一位为0的种数
//dp[i][j][1]表示fun值为j的i位二进制数的最后一位为1的种数
void fun()
{
dp[1][0][0] = 1;
dp[1][0][1] = 1;
for(int i = 2;i <= 100;i++)
for(int j = 0;j < i;j++)
{
dp[i][j][0] = dp[i - 1][j][0] + dp[i - 1][j][1];
dp[i][j][1] = dp[i - 1][j][0];
if(j > 0)
dp[i][j][1] += dp[i - 1][j - 1][1];
}
}
int main()
{
memset(dp,0,sizeof(dp));
fun();
int k;
scanf("%d",&k);
while(k--)
{
int n,p;
scanf("%d%d",&n,&p);
printf("%lld\n",dp
[p][0] + dp
[p][1]);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: