您的位置:首页 > 运维架构

HDU 1673 Optimal Parking(看懂就是水题)

2016-05-06 13:17 453 查看


Optimal Parking


Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2259 Accepted Submission(s): 1884



[align=left]Problem Description[/align]
When shopping on Long Street, Michael usually parks his car at some random location, and then walks to the stores he needs.

Can you help Michael choose a place to park which minimises the distance he needs to walk on his shopping round?

Long Street is a straight line, where all positions are integer.

You pay for parking in a specific slot, which is an integer position on Long Street. Michael does not want to pay for more than one parking though. He is very strong, and does not mind carrying all the bags around.

[align=left]Input[/align]
The first line of input gives the number of test cases, 1 <= t <= 100. There are two lines for each test case. The first gives the number of stores Michael wants to visit, 1 <= n <= 20, and the second
gives their n integer positions on Long Street, 0 <= xi <= 99.

[align=left]Output[/align]
Output for each test case a line with the minimal distance Michael must walk given optimal parking.

[align=left]Sample Input[/align]

2
4
24 13 89 37
6
7 30 41 14 39 42


[align=left]Sample Output[/align]

152
70


[align=left]Source[/align]
2008
“Insigma International Cup” Zhejiang Collegiate Programming Contest - Warm Up(3)

题解:看了好久才看懂题意.....就是一汉子去逛商店,然后只停其中一个商店的停车场,然后走路去其他商店....求最短的走路距离....其实就是从最小到最大走两次...(看懂就是水题)

AC代码:
#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<cstdlib>
#include<iomanip>
#include<algorithm>
#include<time.h>
typedef long long LL;
using namespace std;

int main()
{
int t,n,a[100];
cin>>t;
while(t--)
{
cin>>n;
for(int i=0;i<n;i++)
cin>>a[i];
sort(a,a+n);
cout<<(a[n-1]-a[0])*2<<endl;
}
return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: