您的位置:首页 > 其它

FZU 2039 Pets(二分匹配裸题)

2016-05-05 13:41 274 查看
Problem Description

Are you interested in pets? There is a very famous pets shop in the center of the ACM city. There are totally m pets in the shop, numbered from 1 to m. One day, there are n customers in the shop, which are numbered from 1 to n. In order to sell pets to as more customers as possible, each customer is just allowed to buy at most one pet. Now, your task is to help the manager to sell as more pets as possible. Every customer would not buy the pets he/she is not interested in it, and every customer would like to buy one pet that he/she is interested in if possible.



Input

There is a single integer T in the first line of the test data indicating that there are T(T≤100) test cases. In the first line of each test case, there are three numbers n, m(0≤n,m≤100) and e(0≤e≤n*m). Here, n and m represent the number of customers and the number of pets respectively.

In the following e lines of each test case, there are two integers x(1≤x≤n), y(1≤y≤m) indicating that customer x is not interested in pet y, such that x would not buy y.

Output

For each test case, print a line containing the test case number (beginning with 1) and the maximum number of pets that can be sold out.

Sample Input

1

2 2 2

1 2

2 1

Sample Output

Case 1: 2

Source

2011年全国大学生程序设计邀请赛(福州)

本题是一道裸的二分匹配题目。

就是怎么样匹配才能使更多的人满意。

下面是AC代码:

#include<cstdio>
#include<cstring>

int e[101][101];
int match[101];
int book[101];
int n,m;
int dfs(int u)
{
int i;
for(int i=1; i<=n; i++)
{
if(book[i]==0&&e[u][i]==0)
{
book[i]=1;
if(match[i]==0||dfs(match[i]))
{
match[i]=u;
return 1;
}
}
}
return 0;
}
int main()
{
int i,j,t1,t2,sum=0,q;
int t;
int iCase=0;
scanf("%d",&t);
while(t--)
{
sum=0;
iCase++;
memset(e,0,sizeof(e));
memset(book,0,sizeof(book));
scanf("%d%d%d",&n,&m,&q);
for(i=0; i<q; i++)
{
scanf("%d%d",&t1,&t2);
e[t2][t1]=1;
//e[t2][t1]=1;
}
for(i=1; i<=n; i++)
{
match[i]=0;
}
for(i=1; i<=m; i++)
{
for(j=1; j<=m; j++)
{
book[j]=0;
}
if(dfs(i))
{
sum++;
}
}
printf("Case %d: ",iCase);
printf("%d\n",sum);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: