您的位置:首页 > 产品设计 > UI/UE

hdu——1711Number Sequence(kmp专练)

2016-05-04 23:03 337 查看
Number Sequence

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 19556 Accepted Submission(s): 8389

Problem Description

Given two sequences of numbers : a[1], a[2], ...... , a
, and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one
K exist, output the smallest one.

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a
.
The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input

2

13 5

1 2 1 2 3 1 2 3 1 3 2 1 2

1 2 3 1 3

13 5

1 2 1 2 3 1 2 3 1 3 2 1 2

1 2 3 2 1

Sample Output

6

-1

Source

HDU 2007-Spring Programming Contest

Recommend

lcy

可以用单个数字输入抵消空格的影响 不直接用string 进行kmp算法

#include<iostream>
#include<string>
#include<cstring>
using namespace std;
int nexta[4000100];
int a[1000100],b[1000010];//a是子串b是模板
void getnext(int a[],long long h)
{
int i=0,j=-1;
nexta[0]=-1;
while(i<h)
{
if(j==-1||a[i]==a[j])
{
++i;
++j;
nexta[i]=j;
}
else j=nexta[j];
}
}
long long kmp(int a[],long long h,int b[],long long k)
{
int i=0,j=0;
while(i<k)
{
if(a[j]==b[i]||j==-1)
{
++i;
++j;
}
else j=nexta[j];
if(j==h)
{
return i-h+1;//从0开始的
}
}
return -1;
}
int main()
{
long long h,k,i,n;
ios::sync_with_stdio(false);
cin>>n;
while(n--)
{
cin>>k>>h;
for(i=0;i<k;i++)
cin>>b[i];
for(i=0;i<h;i++)
cin>>a[i];
getnext(a,h);
cout<<kmp(a,h,b,k)<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: