您的位置:首页 > 大数据 > 人工智能

CodeForces - 667A Pouring Rain (数学模拟)水

2016-05-04 22:29 543 查看
CodeForces - 667A
Pouring Rain

Time Limit: 1000MS Memory Limit: 262144KB 64bit IO Format: %I64d & %I64u
SubmitStatus

Description

A lot of people in Berland hates rain, but you do not. Rain pacifies, puts your thoughts in order. By these years you have developed a good tradition — when it rains, you go on the street and stay silent for a moment, contemplate all around you, enjoy freshness,
think about big deeds you have to do.

Today everything had changed quietly. You went on the street with a cup contained water, your favorite drink. In a moment when you were drinking a water you noticed that the process became quite long: the cup still contained water because of rain. You decided
to make a formal model of what was happening and to find if it was possible to drink all water in that situation.

Thus, your cup is a cylinder with diameter equals d centimeters. Initial level of water in cup equals
h centimeters from the bottom.



You drink a water with a speed equals v milliliters per second. But rain goes with such speed that if you do not drink a water from the cup, the level of water increases on
e centimeters per second. The process of drinking water from the cup and the addition of rain to the cup goes evenly and continuously.

Find the time needed to make the cup empty or find that it will never happen. It is guaranteed that if it is possible to drink all water, it will happen not later than after
104 seconds.

Note one milliliter equals to one cubic centimeter.

Input

The only line of the input contains four integer numbers
d, h, v, e (1 ≤ d, h, v, e ≤ 104), where:

d — the diameter of your cylindrical cup,

h — the initial level of water in the cup,

v — the speed of drinking process from the cup in milliliters per second,

e — the growth of water because of rain if you do not drink from the cup.

Output

If it is impossible to make the cup empty, print "NO" (without quotes).

Otherwise print "YES" (without quotes) in the first line. In the second line print a real number — time in seconds needed the cup will be empty. The answer will be considered correct if its relative or absolute error
doesn't exceed 10 - 4. It is guaranteed that if the answer exists, it doesn't exceed
104.

Sample Input

Input
1 2 3 100


Output
NO


Input
1 1 1 1


Output
YES
3.659792366325


Sample Output

Hint

Source
Codeforces Round #349 (Div. 2)
//题意:
给你四个数d,h,v,e,表示给你一个水桶直径为d,里面的水的高度为h,现在人喝水的速度为v  ml/s,在人不喝水是,雨水使水平面上升的的速度为c  cm/s,问人在下着雨的时候又喝着水,是否可以把水喝完,若喝完输出时间。
//思路:
很水的数学水题,就不多说了
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#define PI acos(-1.0)
using namespace std;
int main()
{
double d,h,v,e;
double t;
while(scanf("%lf%lf%lf%lf",&d,&h,&v,&e)!=EOF)
{
double S=PI*d*d*0.25;
double V=S*h;
double ve=S*e;
if(ve>=v)
printf("NO\n");
else
{
t=V/(v-ve);
printf("YES\n%lf\n",t);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: