您的位置:首页 > 其它

hdu2072——单词数(STL,set)

2016-05-04 20:46 387 查看
Problem Description

lily的好朋友xiaoou333最近很空,他想了一件没有什么意义的事情,就是统计一篇文章里不同单词的总数。下面你的任务是帮助xiaoou333解决这个问题。

Input

有多组数据,每组一行,每组就是一篇小文章。每篇小文章都是由小写字母和空格组成,没有标点符号,遇到#时表示输入结束。

Output

每组只输出一个整数,其单独成行,该整数代表一篇文章里不同单词的总数。

Sample Input

you are my friend

#

Sample Output

4

set的用法

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <queue>
#include <vector>
#include <iostream>
#include <set>
#include <cstring>
#include <string>
#define MAXN 1000010
#define inf 0xffffffff
using namespace std;
set<string> hehe;
int main()
{
int j,cnt;
string a,b;
while(getline(cin,a))
{
j=0;
cnt=0;
if(a[0]=='#')
break;
int la=a.length();
b="";
for(int i=0; i<la; ++i)
{
if(a[i]!=' ')
{
b+=a[i];
if(i==la-1)
{
if(hehe.find(b)==hehe.end())
{
cnt++;
hehe.insert(b);
}
}
}
else
{
j=0;
if(b[0]>='a'&&b[0]<='z')
{
if(hehe.find(b)==hehe.end())
{
cnt++;
hehe.insert(b);
}
}
b="";
}
}
hehe.clear();
printf("%d\n",cnt);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: