您的位置:首页 > 其它

杭电ACM 1001

2016-05-04 19:02 330 查看

Sum Problem

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 406156    Accepted Submission(s): 102002


[align=left]Problem Description[/align]
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.

 

[align=left]Input[/align]
The input will consist of a series of integers n, one integer per line.

 

[align=left]Output[/align]
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.

 

[align=left]Sample Input[/align]

1
100

 

[align=left]Sample Output[/align]

1

5050
#include<iostream>
using namespace std;

int main(){
int a;
while(cin>>a){
if(0==a%2)///防止溢出
cout<<(a/2*(a+1))<<endl<<endl;
else
cout<<(a+1)/2*a<<endl<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm 杭电