您的位置:首页 > 其它

O

2016-05-03 20:43 274 查看

Time Limit : 1000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)


Total Submission(s) : 16   Accepted Submission(s) : 13


Problem Description

Give you a number on base ten,you should output it on base two.(0 < n < 1000)

 

Input

For each case there is a postive number n on base ten, end of file.

 

Output

For each case output a number on base two.

 

Sample Input

1
2
3

 

Sample Output

1
10
11
题目大意:10进制转二进制
思路:%2去余数存数组倒着输出
代码:#include<iostream>
#include<string.h>
using namespace std;
int main()
{

 int n,a[32];

   while( cin>>n)
   { int i=0;
   memset(a,0,sizeof(a));
   while (n>0)
    {
        a[i]=n%2;
        i=i+1;
        n=n/2;
    }
     i--;
    for(;i>=0;i--)
    cout<<a[i];
 cout<<endl;
 }

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: