您的位置:首页 > Web前端

HDU 4715:Difference Between Primes

2016-05-01 20:05 337 查看


Difference Between Primes

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3339    Accepted Submission(s): 953


Problem Description

All you know Goldbach conjecture.That is to say, Every even integer greater than 2 can be expressed as the sum of two primes. Today, skywind present a new conjecture: every even integer can be expressed as the difference of two primes. To validate this conjecture,
you are asked to write a program.

 

Input

The first line of input is a number nidentified the count of test cases(n<10^5). There is a even number xat the next nlines. The absolute value of xis not greater than 10^6.

 

Output

For each number xtested, outputstwo primes aand bat one line separatedwith one space where a-b=x. If more than one group can meet it, output the minimum group. If no primes can satisfy it, output 'FAIL'.

 

Sample Input

3
6
10
20

 

Sample Output

11 5
13 3
23 3

 

Source

2013 ACM/ICPC Asia Regional Online —— Warmup

 


迷失在幽谷中的鸟儿,独自飞翔在这偌大的天地间,却不知自己该飞往何方……

#include<iostream>
using namespace std;
const long N = 1000005;
long prime
,num_prime;
int isNotPrime
= {1, 1};
void getprime()
{
for(long i = 2 ; i < N ; i ++)
{
if(!isNotPrime[i])prime[num_prime ++]=i;
for(long j = 0 ; j < num_prime && i * prime[j] <  N ; j ++)
{
isNotPrime[i * prime[j]] = 1;
if(!(i%prime[j]))break;
}
}
}
int main()
{
getprime();
int T,n,s,a;
cin>>T;
while(T--)
{
cin>>n;
a=n>0?n:-n;
s=0;
for(int i=0; i<100000; i++)
if(!isNotPrime[prime[i]+a])
{
if(n>0) cout<<prime[i]+a<<" "<<prime[i]<<endl;
else cout<<prime[i]<<" "<<prime[i]+a<<endl;
s=1;
break;
}
if(s==0)cout<<"FAIL"<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: