您的位置:首页 > 其它

ZOJ - 3870 Team Formation (位运算)

2016-05-01 15:31 429 查看
ZOJ - 3870
Team Formation

Time Limit:                                                        3000MS                        Memory Limit:                                                        131072KB                        64bit IO Format:                            %lld & %llu                       
SubmitStatus

Description

For an upcoming programming contest, Edward, the headmaster of Marjar University, is forming a two-man team from
N students of his university.

Edward knows the skill level of each student. He has found that if two students with skill level
A and B form a team, the skill level of the team will be
A ⊕ B, where ⊕ means bitwise exclusive or. A team will play well if and only if the skill level of the team is greater than the skill level of each team member (i.e.
A ⊕ B > max{A, B}).

Edward wants to form a team that will play well in the contest. Please tell him the possible number of such teams. Two teams are considered different if there is at least one different team member.

<h4< body="">

Input

There are multiple test cases. The first line of input contains an integer
T indicating the number of test cases. For each test case:

The first line contains an integer N (2 <= N <= 100000), which indicates the number of student. The next line contains
N positive integers separated by spaces. The ith integer denotes the skill level of
ith student. Every integer will not exceed 109.

<h4< body="">

Output

For each case, print the answer in one line.

<h4< body="">

Sample Input

2
3
1 2 3
5
1 2 3 4 5

<h4< body="">

Sample Output

1
6


Hint

Source
The 12th Zhejiang Provincial Collegiate Programming Contest
//题意:输入一个n,接下来输入n个数。
现在有n个人,n个数代表他们的分数,现在要求从中选出来两个人,并且要求这两个人的异或值要大于这两个数,问有几种情况。
//思路:
因为是异或值所以只用使得两个数的高位上对应的位置出现0和1就可以得到比他俩大的数了。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstring>
#include<algorithm>
const int MAXN = 100010;
int a[MAXN], num[100];
typedef long long LL;
int geth(int x)
{
int i;
for(i = 0;;i++)
{
if((1 << i) > x)
break;
}
return i;
}
int main()
{
int T, N;
scanf("%d", &T);
while(T--)
{
memset(num, 0, sizeof(num));
scanf("%d", &N);
for(int i = 0; i < N; i++)
{
scanf("%d", a + i);
num[geth(a[i])]++;
}
LL ans = 0;
for(int i = 0; i < N; i++)
{
if(a[i] > 0 && a[i] % 2 == 0)
ans += num[0];
for(int j = 1; (1 << (j - 1)) < a[i]; j++)
{
if((a[i] ^ (1 << (j - 1))) > a[i])
ans += num[j];
}
}
printf("%lld\n", ans);
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: