您的位置:首页 > 其它

ZOJ - 3869 Ace of Aces (水)

2016-05-01 15:12 621 查看
ZOJ - 3869
Ace of Aces

Time Limit: 2000MS Memory Limit: 65536KB 64bit IO Format: %lld & %llu
SubmitStatus

Description

There is a mysterious organization called Time-Space Administrative Bureau (TSAB) in the deep universe that we humans have not discovered yet. This year, the TSAB decided to elect an outstanding member from its elite troops. The elected guy will
be honored with the title of "Ace of Aces".

After voting, the TSAB received N valid tickets. On each ticket, there is a number
Ai denoting the ID of a candidate. The candidate with the most tickets nominated will be elected as the "Ace of Aces". If there are two or more candidates have the same number of nominations, no one will win.

Please write program to help TSAB determine who will be the "Ace of Aces".

<h4< body="">

Input

There are multiple test cases. The first line of input contains an integer
T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 1000). The next line contains
N integers Ai (1 <= Ai <= 1000).

<h4< body="">

Output

For each test case, output the ID of the candidate who will be honored with "Ace of Aces". If no one win the election, output "Nobody" (without quotes) instead.

<h4< body="">

Sample Input

3
5
2 2 2 1 1
5
1 1 2 2 3
1
998

<h4< body="">

Sample Output

2
Nobody
998


Hint

Source
The 12th Zhejiang Provincial Collegiate Programming Contest
//题意:
找出出现次数最多的数,如果有多个输出Nobody

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;
const int MAXN = 1010;
int num[MAXN];
int p[MAXN];
int main(){
int T, N;
scanf("%d", &T);
while(T--){
memset(num, 0, sizeof(num));
memset(p, 0, sizeof(p));
scanf("%d", &N);
int x;
for(int i = 0; i < N; i++){
scanf("%d", &x);
num[x]++;
}
int ans = 0, temp = 0;
for(int i = 0; i < MAXN; i++){
if(num[i] >= temp){
temp = num[i];
ans = i;
p[temp]++;
}
}
if(p[num[ans]] > 1){
puts("Nobody");
}
else
printf("%d\n", ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: