您的位置:首页 > Web前端

NYOJ 791 Color the fence

2016-04-30 21:23 302 查看

Color the fence

时间限制:1000 ms | 内存限制:65535 KB
难度:2

描述

Tom has fallen in love with Mary. Now Tom wants to show his love and write a number on the fence opposite to

Mary’s house. Tom thinks that the larger the numbers is, the more chance to win Mary’s heart he has.

Unfortunately, Tom could only get V liters paint. He did the math and concluded that digit i requires ai liters paint.

Besides,Tom heard that Mary doesn’t like zero.That’s why Tom won’t use them in his number.

Help Tom find the maximum number he can write on the fence.

输入There are multiple test cases.

Each case the first line contains a nonnegative integer V(0≤V≤10^6).

The second line contains nine positive integers a1,a2,……,a9(1≤ai≤10^5).输出Printf the maximum number Tom can write on the fence. If he has too little paint for any digit, print -1.样例输入
5


5 4 3 2 1 2 3 4 5


2


9 11 1 12 5 8 9 10 6

样例输出
55555


33

来源CodeForce上传者
TC_李远航

题意就是输入的九个数分别对应1,2,3,4......9,一开始题意理解了好久QAQ

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
using namespace std;
int a[1000005];
int main(){
int n,min,t,i,sum,j;
while(~scanf("%d",&n)){
min=100005; t=-1;
for(i=1;i<10;i++){
scanf("%d",&a[i]);
if(a[i]<min&&i>t){
min=a[i];
t=i;
}//找出用颜料最少的最大的一位数 min
}
if(min>n){
printf("-1\n");
continue;
} //不可能的情况排除
sum=n/min;//组成的一串数的最大位数
for(i=sum-1;i>=0;i--){
for(j=9;j>=1;j--){
if(n-a[j]>=0&&(n-a[j])/min>=i){//相当于设第一位之后各位都是用料最小的数字,然后找第一位。。。第n位
n-=a[j];
printf("%d",j);
break;
}
}
}//包含颜料写同一数字刚好用完 和 用不完的情况
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: