您的位置:首页 > 其它

ZOJ_1016

2016-04-30 15:25 260 查看



ZOJ_1016: Parencodings

Time Limit: 2000 MS Memory Limit: 64 MB
64bit IO Format: %lld

Submitted: 0 Accepted: 0

[Submit][Status][Web
Board]


Description

Let S = s1 s2 ... s2n be a well-formed string of parentheses. S can be encoded in two different ways:

By an integer sequence P = p1 p2 ... pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).
By an integer sequence W = w1 w2 ... wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).

Following is an example of the above encodings:

S (((()()())))

P-sequence 4 5 6666

W-sequence 1 1 1456

Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.


Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed
string. It contains n positive integers, separated with blanks, representing the P-sequence.


Output

The output consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.


Sample Input


2
6
4 5 6 6 6 6
9
4 6 6 6 6 8 9 9 9



Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9



Source

Asia 2001, Tehran (Iran)

这道题目不要想的太复杂了,先把串给模拟出来比较好

#include<cstdio>

using namespace std;

int n;

int a[100];

char ss[1000];

int ans[1000];

int anslen;

int main()

{

int T;

scanf("%d",&T);

while(T--)

{

anslen=0;

scanf("%d",&n);

for(int i=0;i<n;i++)

scanf("%d",&a[i]);

int len=0;

for(int i=0;i<a[0];i++)

ss[len++]='(';

ss[len++]=')';

for(int i=1;i<n;i++)

{

for(int j=0;j<a[i]-a[i-1];j++)

ss[len++]='(';

ss[len++]=')';

}

ss[len]='\0';

int num=0;

anslen=0;

for(int i=0;i<len;i++)

{

if(ss[i]=='(')

continue;

int counl=0,counr=1;

for(int j=i-1;j>=0;j--)

{

if(ss[j]=='(')

counl++;

else

counr++;

if(counl==counr)

{

ans[anslen++]=counl;

break;

}

}

}

for(int i=0;i<anslen;i++)

{

if(i)

printf(" ");

printf("%d",ans[i]);

}

puts("");

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: