您的位置:首页 > 其它

C - How Many Tables——HOJ

2016-04-30 14:46 295 查看
C - How Many Tables
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d
& %I64u
Submit Status

Description

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want
to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked
from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input

2
5 3
1 2
2 3
4 5

5 1
2 5


Sample Output

2
4


#include<stdio.h>
#include<string.h>
#include<math.h>
#define MAX 3100
void make_set();
int getf(int x);
void union_set(int a,int b);
int m,n;
int parent[MAX];
int T;
int main()
{
scanf("%d",&T);
for(int k=1;k<=T;k++)
{
int x,y;
scanf("%d %d",&n,&m);
make_set();
for(int i=1;i<=m;i++)
{
scanf("%d %d",&x,&y);
union_set(x,y);
}
for(int i=1;i<=n;i++) 	getf(i) ;

int sum=0;

for(int i=1;i<=n;i++)
{
if(parent[i]==i)
sum++;
}
printf("%d\n",sum);

}
return 0;
}

void make_set()
{
for(int i=1;i<=n;i++)
{
parent[i]=i;
}
}

int getf(int x)//寻找祖先,并回溯缩短路径
{
if(x!=parent[x])
{
parent[x]=getf(parent[x]);
}
return parent[x];
}
void union_set(int a,int b)//合并两个集合
{
int t1=getf(a);
int t2=getf(b);
if(t1!=t2)
{
parent[t2]=t1;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: