您的位置:首页 > 其它

HDU-4493 Tutor (模拟)

2016-04-30 14:26 323 查看


Tutor

http://acm.hdu.edu.cn/showproblem.php?pid=4493

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65535/65535 K (Java/Others)



Problem Description

Lilin was a student of Tonghua Normal University. She is studying at University of Chicago now. Besides studying, she worked as a tutor teaching Chinese to Americans. So, she can earn some money per month. At the end of the year, Lilin wants to know his average
monthly money to decide whether continue or not. But she is not good at calculation, so she ask for your help. Please write a program to help Lilin to calculate the average money her earned per month.

Input

The first line contain one integer T, means the total number of cases.

Every case will be twelve lines. Each line will contain the money she earned per month. Each number will be positive and displayed to the penny. No dollar sign will be included.

Output

The output will be a single number, the average of money she earned for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign without tail zero. There will be no other spaces or characters in the output.

Sample Input

2
100.00
489.12
12454.12
1234.10
823.05
109.20
5.27
1542.25
839.18
83.99
1295.01
1.75
100.00
100.00
100.00
100.00
100.00
100.00
100.00
100.00
100.00
100.00
100.00
100.00


Sample Output

$1581.42
$100


题目大意:求12个数的平均数,没有末尾0

其实早就发现了0.5的舍入各个编译器有差别,但是一般加上EPS就能过了,但是本题在重现时貌似得手动判断。。。

#include <cstdio>

using namespace std;

int main() {
int T,tmp;
double a,ans;
scanf("%d",&T);
while(T-->0) {
ans=0;
for(int i=0;i<12;++i) {
scanf("%lf",&a);
ans+=a;
}
ans=ans/12;
tmp=int(ans*100+0.5);
if(tmp%100==0) {
printf("$%.0lf\n",ans);
}
else if(tmp%10==0) {
printf("$%.1lf\n",ans);
}
else {
printf("$%.2lf\n",ans);
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: