您的位置:首页 > 其它

POJ-2253-Frogger

2016-04-30 12:57 453 查看
A - Frogger

Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u

Submit

Status

Practice

POJ 2253

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists’ sunscreen, he wants to avoid swimming and instead reach her by jumping.

Unfortunately Fiona’s stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.

To execute a given sequence of jumps, a frog’s jump range obviously must be at least as long as the longest jump occuring in the sequence.

The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy’s stone, Fiona’s stone and all other stones in the lake. Your job is to compute the frog distance between Freddy’s and Fiona’s stone.

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy’s stone, stone #2 is Fiona’s stone, the other n-2 stones are unoccupied. There’s a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying “Scenario #x” and a line saying “Frog Distance = y” where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2

0 0

3 4

3

17 4

19 4

18 5

0

Sample Output

Scenario #1

Frog Distance = 5.000

Scenario #2

Frog Distance = 1.414

题意:多组输入,第一行输入n,接下来n行,每行给出一组坐标,第一第二坐标是起点和终点,剩下的是可以中转的点。找到一条路径,使得路径上相邻两点的距离尽可能小,输出尽可能小的距离中最大的那个距离(不算难理解吧)

思路:贪心,动规,最短路,就是这些思想。具体用迪杰斯特拉或者弗洛伊德都可以实现

代码

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<math.h>
#include<iomanip>
using namespace std;
const int maxn=205;
double map[maxn][maxn];//建图
struct node
{
double xi;
double yi;
} num[maxn]; //接收坐标
int main()
{
int n;//地图尺寸
int casen=1;
while(~scanf("%d",&n)&&n)
{
for(int i=1; i<=n; i++)//读取数据
{
scanf("%lf%lf",&num[i].xi,&num[i].yi);
for(int j=1; j<i; j++)//建图
map[i][j]=map[j][i]=sqrt((num[i].xi-num[j].xi)*(num[i].xi-num[j].xi)+(num[i].yi-num[j].yi)*(num[i].yi-num[j].yi));
}
for(int k=1; k<=n; k++)
for(int i=1; i<=n; i++)
for(int j=1; j<=n; j++)
if(map[i][k]<map[i][j]&&map[k][j]<map[i][j])
map[i][j]=map[j][i]=max(map[i][k],map[k][j]);
printf("Scenario #%d\n",casen++);
cout<<fixed<<setprecision(3)<<"Frog Distance = "<<map[1][2]<<endl<<endl;
getchar();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: