您的位置:首页 > 其它

HDU 2844 二进制优化的多重背包

2016-04-30 00:28 323 查看

Coins

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11596 Accepted Submission(s): 4634


[align=left]Problem Description[/align]
Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.

[align=left]Input[/align]
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.

[align=left]Output[/align]
For each test case output the answer on a single line.

[align=left]Sample Input[/align]

3 10

1 2 4 2 1 1

2 5

1 4 2 1
0 0

[align=left]Sample Output[/align]

8

4

[align=left]Source[/align]
2009 Multi-University Training Contest 3 - Host by WHU

题意:有不同面值的 相应数量不同n种硬币 问1~m元的价格有哪些 可以由硬币组成 f[i]==i

题解: 多重背包 二进制优化

#include<iostream>
#include<cstring>
#include<cstdio>
#include<map>
#include<queue>
#include<stack>
using namespace std;
int n,m;
struct node
{
int a,c;
} N[105];
int f[110005];
int ans;
int value[100005],size[100005];
int count;
void slove(int q)
{
count=1;
for(int i=1;i<=q;i++)
{
int c=N[i].c,v=N[i].a;
for (int k=1; k<=c; k<<=1)
{
value[count] = k*v;
size[count++] = k*v;
c -= k;
}
if (c > 0)
{
value[count] = c*v;
size[count++] = c*v;
}
}
}
int main()
{
while(scanf("%d %d",&n,&m)!=EOF)
{
if(n==0&&m==0)
break;
for(int i=0; i <= m; i++)
f[i] = 0;
ans=0;
for(int i=1;i<=n;i++)
scanf("%d",&N[i].a);
for(int i=1;i<=n;i++)
scanf("%d",&N[i].c);
slove(n);
for(int i=1;i<count;i++)
for(int gg=m;gg>=size[i];gg--)
f[gg]=max(f[gg],f[gg-size[i]]+value[i]);
for(int i=1;i<=m;i++)
if(f[i]==i)
ans++;
cout<<ans<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: