您的位置:首页 > 产品设计 > UI/UE

POJ 1679:The Unique MST 次小生成树

2016-04-29 17:58 447 查看
The Unique MST

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 26359 Accepted: 9416
Description

Given a connected undirected graph, tell if its minimum spanning tree is unique. 

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties: 

1. V' = V. 

2. T is connected and acyclic. 

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all
the edges in E'. 

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a
triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.
Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.
Sample Input
2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output
3
Not Unique!


求最小生成树是否唯一。

先求出最小生成树的值,然后枚举删的边,看用剩下的边去构造最小生成树,其实也就是次小生成树,然后判断结果是否与最小生成树的值相等,这里注意生成的次小生成树,最终也要构成一个树,即要判定num==n-1。(没有判定这块wa了一次)。

代码:

#pragma warning(disable:4996)
#include <iostream>
#include <functional>
#include <algorithm>
#include <cstring>
#include <vector>
#include <string>
#include <cstdio>
#include <cmath>
#include <queue>
#include <stack>
#include <deque>
#include <set>
#include <map>
using namespace std;
typedef long long ll;

#define INF 0x333f3f3f
#define repp(i, n, m) for (int i = n; i <= m; i++)
#define rep(i, n, m) for (int i = n; i < m; i++)
#define sa(n) scanf("%d", &(n))

const ll mod = 1e9 + 7;
const int maxn = 2e5 + 5;
const double PI = acos(-1.0);

int n, m;
int fa[maxn], used[maxn];
struct ed
{
int u;
int v;
int w;
}edge[maxn];

bool cmp(ed &a,ed &b)
{
return a.w < b.w;
}

void init()
{
repp(i, 1, n)
{
fa[i] = i;
}
}

int getfa(int x)
{
return x == fa[x] ? x : getfa(fa[x]);
}

void solve()
{
int i, j, k;
sa(n), sa(m);
repp(i, 1, m)
{
sa(edge[i].u), sa(edge[i].v), sa(edge[i].w);
}
sort(edge + 1, edge + m + 1, cmp);

int num, res = 0, cnt = 0;
init();
repp(i, 1, m)
{
int x = getfa(edge[i].u);
int y = getfa(edge[i].v);
if (x == y)continue;
res += edge[i].w;
fa[x] = y;
cnt++;
used[cnt] = i;
}

for (i = 1; i <= cnt; i++)
{
init();
int r = 0;
num = 0;
for (j = 1; j <= m; j++)
{
if (j == used[i])continue;
int x = getfa(edge[j].u);
int y = getfa(edge[j].v);
if (x == y)continue;
num++;
r += edge[j].w;
fa[x] = y;
}
if (r == res&&num == n - 1)
{
puts("Not Unique!");
return;
}
}
printf("%d\n", res);
}

int main()
{
#ifndef ONLINE_JUDGE
freopen("i.txt", "r", stdin);
freopen("o.txt", "w", stdout);
#endif
int t;
scanf("%d", &t);

while (t--)
{
solve();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: