您的位置:首页 > 其它

SDAU 课程练习3 1015

2016-04-29 12:48 183 查看


Problem O


Time Limit : 1000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)


Total Submission(s) : 12   Accepted Submission(s) : 9


Problem Description

Give you a number on base ten,you should output it on base two.(0 < n < 1000)

 

Input

For each case there is a postive number n on base ten, end of file.

 

Output

For each case output a number on base two.

 

Sample Input

1
2
3

 

Sample Output

1
10
11

 

题目大意:

输出二进制.....

思路:

用的正常的方法。。

感想:

为什么这个也在动态规划中出现。。

AC代码:

#include <iostream>
#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int main()
{
long long int a,T,n,m,i,j,temp,k,b;
int arr[100005];
while(cin>>a)
{
i=0;
while(a!=0)
{
arr[i]=a%2;
a/=2;
i++;
}
for(i--;i>=0;i--)
cout<<arr[i];
cout<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: