您的位置:首页 > 其它

hdu 5671 Matrix(BC——思维题)

2016-04-28 21:22 309 查看
题目链接:acm.hdu.edu.cn/showproblem.php?pid=5671


Matrix

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 891    Accepted Submission(s): 371

Problem Description

There is a matrix M that
has n rows
and m columns (1≤n≤1000,1≤m≤1000).Then
we perform q(1≤q≤100,000) operations:

1 x y: Swap row x and row y (1≤x,y≤n);

2 x y: Swap column x and column y (1≤x,y≤m);

3 x y: Add y to all elements in row x (1≤x≤n,1≤y≤10,000);

4 x y: Add y to all elements in column x (1≤x≤m,1≤y≤10,000);

 

Input

There are multiple test cases. The first line of input contains an integer T(1≤T≤20) indicating
the number of test cases. For each test case:

The first line contains three integers n, m and q.

The following n lines
describe the matrix M.(1≤Mi,j≤10,000) for
all (1≤i≤n,1≤j≤m).

The following q lines
contains three integers a(1≤a≤4), x and y.

 

Output

For each test case, output the matrix M after
all q operations.

 

Sample Input

2
3 4 2
1 2 3 4
2 3 4 5
3 4 5 6
1 1 2
3 1 10
2 2 2
1 10
10 1
1 1 2
2 1 2

 

Sample Output

12 13 14 15
1 2 3 4
3 4 5 6
1 10
10 1

Hint Recommand to use scanf and printf

 

Source

BestCoder Round #81 (div.2)

 
题目大意:
有一个nn行mm列的矩阵(1 \leq n \leq 1000 ,1 \leq m \leq 1000 )(1≤n≤1000,1≤m≤1000),在这个矩阵上进行qq  (1 \leq q \leq 100,000)(1≤q≤100,000) 个操作:

1 x y: 交换矩阵MM的第xx行和第yy行(1 \leq x,y \leq n)(1≤x,y≤n);
2 x y: 交换矩阵MM的第xx列和第yy列(1 \leq x,y \leq m)(1≤x,y≤m);
3 x y: 对矩阵MM的第xx行的每一个数加上y(1 \leq x \leq n,1 \leq y \leq 10,000)y(1≤x≤n,1≤y≤10,000);
4 x y: 对矩阵MM的第xx列的每一个数加上y(1 \leq x \leq m,1 \leq y \leq 10,000)y(1≤x≤m,1≤y≤10,000);对于每组数据,输出经过所有q个操作之后的矩阵M。


解题思路:如果单纯进行模拟的话,数据量比较大,所以采用标记的方式。分别记录当前状态下每一行、每一列是原始数组的哪一行、哪一列即可。对每一行、每一列加一个数的操作,也可以两个数组分别记录。注意当交换行、列的同时,也要交换增量数组。输出时通过索引找到原矩阵中的值,再加上行、列的增量。

详见代码。

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

int Map[1010][1010],a;
int h[1010],l[1010],dh[1010],dl[1010];

int main()
{
int T;
scanf("%d",&T);
while (T--)
{
memset(dh,0,sizeof(dh));
memset(dl,0,sizeof(dl));
int n,m,q;
scanf("%d%d%d",&n,&m,&q);
for (int i=1; i<=n; i++)
{
for (int j=1; j<=m; j++)
{
scanf("%d",&Map[i][j]);
h[i]=i;
l[j]=j;
}
}
for (int i=0; i<q; i++)
{
int a,x,y;
scanf("%d%d%d",&a,&x,&y);

if(a==1)
{
swap(h[x],h[y]);
swap(dh[x],dh[y]);//交换要加的数字
}
else if(a==2)
{
swap(l[x],l[y]);
swap(dl[x],dl[y]);
}
else if(a==3)
{
dh[x]+=y;
}
else if(a==4)
{
dl[x]+=y;
}
}
for (int i=1; i<=n; i++)
{
for (int j=1; j<m; j++)
printf ("%d ",Map[h[i]][l[j]]+dh[i]+dl[j]);
printf ("%d\n",Map[h[i]][l[m]]+dh[i]+dl[m]);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: