您的位置:首页 > 其它

POJ 1328 Radar Installation

2016-04-28 20:46 302 查看
Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the
sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write
a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.



Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing
two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2

1 2

-3 1

2 1

1 2

0 2

0 0

Sample Output

Case 1: 2

Case 2: 1

题意为,在一个坐标系中,x轴代表海岸,x轴以上有n个点,代表着n个岛屿,在x轴上建雷达,一直雷达的覆盖范围为半径为d的圆,求在x轴上最少建多少个雷达,才能把全部的岛屿覆盖起来,如果不能覆盖,输出-1.

这题变相考区间不相交问题。以岛屿为圆心,以雷达的覆盖范围为半径画圆,与x轴交于两点,在这两点之间建雷达一定可以覆盖这个岛屿。这两点就是这个岛屿的可行区间,

岛屿之间的可行区间不相交就说明需要再建雷达,不能共用一个雷达。

注意精度问题,因为这错了好几次。

#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstdio>
using namespace std;
struct nde
{
double x,y;
} a[1001];
bool cmp(nde x1,nde y1)
{
return x1.y<y1.y;
}
int main()
{
int l=0,flag,n,i,k;
double r;
while(~scanf("%d%lf",&n,&r)&&n&&r)
{
l++;
flag=0;
for(i=0; i<n; i++)
scanf("%lf%lf",&a[i].x,&a[i].y);
cout<<"Case "<<l<<": ";
for(i=0; i<n; i++)
{
if(a[i].y>r)
{
flag=1;
cout<<-1<<endl;
break;
}
if(a[i].y==r)
a[i].y=a[i].x;
else
{///将坐标转化为区间
double t=sqrt(r*r-a[i].y*a[i].y);
a[i].y=a[i].x+t;
a[i].x=a[i].x-t;
}
}
if(!flag)
{///计算不相交区间个数
k=1;
sort(a,a+n,cmp);
for(i=1; i<n; i++)
{
if(a[i].x>a[0].y)
{
k++;
a[0].y=a[i].y;
}
else
continue;
}
cout<<k<<endl;
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: