您的位置:首页 > 其它

POJ 1837 Balance

2016-04-28 19:41 337 查看
Balance

Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 12792Accepted: 8012
Description
Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance.

It orders two arms of negligible weight and each arm's length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25.
Gigel may droop any weight of any hook but he is forced to use all the weights.

Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced.

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device.

It is guaranteed that will exist at least one solution for each test case at the evaluation.

Input
The input has the following structure:

• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20);

• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis
(when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the
hook is attached: '-' for the left arm and '+' for the right arm);

• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights' values.

Output
The output contains the number M representing the number of possibilities to poise the balance.

Sample Input
2 4
-2 3
3 4 5 8

Sample Output
2


题意:给你c(2<=c<=20)个挂钩,g(2<=g<=20)个砝码,求在将所有砝码(砝码重1~~25)挂到天平(天平长 -15~~15)上,并使得天平平衡的方法数.......

思路:(这是我木有想到的)将g个挂钩挂上的极限值:15*25*20==7500

那么在有负数的情况下是-7500~~7500 以0为平衡点......

那可以将平衡点往右移7500个单位,范围就是0~~15000......这样就好处理多了

其实我觉得以后的题目中不仅仅天平问题可以这样处理,在有负数的以及要装入数组处理的题目中,我们都可以尝试着平移简化问题......

这题目是要将所有的砝码都挂到天平上后的最多方法数,同时砝码自带质量,也就是说,这不仅仅有着“容量”的限制,还有着“件数”的限制,很明显的二维费用背包......

每个砝码只能用一次,果断01背包,并且在处理这一状态前,先判断前一状态是否存在......我喜欢用>0表示存在,用0表示不存在,而这个题目又是求方法数,不需要再减去1........

#include <stdio.h>
#include <string.h>
int dp[22][15010], C[22], G[22];
int main()
{
int c, g, i, j, k;
while(scanf("%d%d", &c, &g) != EOF)
{
for(i = 1; i <= c; i++)
scanf("%d", &C[i]);
for(i = 1; i <= g; i++)
scanf("%d", &G[i]);
memset(dp, 0, sizeof(dp));
dp[0][7500] = 1;
for(i = 1; i <= g; i++)
{
for(j = 1; j <= 15000; j++)
{
if(dp[i - 1][j])
{
for(k = 1; k <= c; k++)
{
if(j + C[k] * G[i] >= 0 && j + C[k] * G[i] <= 15000)
dp[i][j + C[k] * G[i]] += dp[i - 1][j];
}
}
}
}
printf("%d\n", dp[g][7500]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: