您的位置:首页 > 其它

poj 1584(综合性强的计算几何,好题)

2016-04-28 19:39 393 查看
A Round Peg in a Ground Hole

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 6238Accepted: 1997
Description

The DIY Furniture company specializes in assemble-it-yourself furniture kits. Typically, the pieces of wood are attached to one another using a wooden peg that fits into pre-cut holes in each piece to be attached. The pegs have a circular cross-section and so are intended to fit inside a round hole.
A recent factory run of computer desks were flawed when an automatic
grinding machine was mis-programmed. The result is an irregularly
shaped hole in one piece that, instead of the expected circular shape,
is actually an irregular polygon. You need to figure out whether the
desks need to be scrapped or if they can be salvaged by filling a part
of the hole with a mixture of wood shavings and glue.

There are two concerns. First, if the hole contains any protrusions
(i.e., if there exist any two interior points in the hole that, if
connected by a line segment, that segment would cross one or more edges
of the hole), then the filled-in-hole would not be structurally sound
enough to support the peg under normal stress as the furniture is used.
Second, assuming the hole is appropriately shaped, it must be big enough
to allow insertion of the peg. Since the hole in this piece of wood
must match up with a corresponding hole in other pieces, the precise
location where the peg must fit is known.

Write a program to accept descriptions of pegs and polygonal holes
and determine if the hole is ill-formed and, if not, whether the peg
will fit at the desired location. Each hole is described as a polygon
with vertices (x1, y1), (x2, y2), . . . , (xn, yn). The edges of the
polygon are (xi, yi) to (xi+1, yi+1) for i = 1 . . . n − 1 and (xn, yn) to (x1, y1).
Input

Input consists of a series of piece descriptions. Each piece description consists of the following data:

Line 1 < nVertices > < pegRadius > < pegX > < pegY >

number of vertices in polygon, n (integer)

radius of peg (real)

X and Y position of peg (real)

n Lines < vertexX > < vertexY >

On a line for each vertex, listed in order, the X and Y position of
vertex The end of input is indicated by a number of polygon vertices
less than 3.
Output

For each piece description, print a single line containing the string:

HOLE IS ILL-FORMED if the hole contains protrusions

PEG WILL FIT if the hole contains no protrusions and the peg fits in the hole at the indicated position

PEG WILL NOT FIT if the hole contains no protrusions but the peg will not fit in the hole at the indicated position
Sample Input

5 1.5 1.5 2.0
1.0 1.0
2.0 2.0
1.75 2.0
1.0 3.0
0.0 2.0
5 1.5 1.5 2.0
1.0 1.0
2.0 2.0
1.75 2.5
1.0 3.0
0.0 2.0
1

Sample Output

HOLE IS ILL-FORMED
PEG WILL NOT FIT

这篇博客有测试数据:http://blog.csdn.net/lyy289065406/article/details/6648606
题意:输入n个点,圆的半径以及圆的坐标X,Y。然后是每个点的x,y坐标.
判断输入的点是不是能够组成凸包,不能的话输出 HOLE IS ILL-FORMED,判断圆是否在凸包内.如果在的话输出PEG WILL FIT.否则输出 PEG WILL NOT FIT
很多模板的综合应用.
这个题判断点是否在多边形内有两种模板:
一种局限性大,只适合按照顺(逆)时针输入的凸多边形,不过很容易理解:


/**判断点是否在凸多边形内(这个比较容易打并且适合这题)*/
bool pointInConvex(int n,double x,double y){
Point po;
p
= p[0];
po.x = x,po.y = y;
bool flag = isCross(cross(p[0],p[1],po)); ///既然是判断了是凸多边形肯定相邻两个点是朝同一个方向转
for(int i=1;i<n;i++){
if(isCross(cross(p[i],p[i+1],po))!=flag){
return false;
}
}
return true;
}


另外一种具有普遍性,什么样子的多边形都OK,大牛总结的:

/**判断点是否在多边形内(具有普遍性,不过并不能看懂)*/
bool pointInPolygon(int n,double x,double y)
{
int   i,j=n-1;
bool  oddNodes=0;
for (i=0; i<n; i++)
{
if((p[i].y< y && p[j].y>=y|| p[j].y<y && p[i].y>=y) && (p[i].x<=x||p[j].x<=x))
{
oddNodes^=(p[i].x+(y-p[i].y)/(p[j].y-p[i].y)*(p[j].x-p[i].x)<x);
}
j=i;
}
return oddNodes;
}


代码:

///题意:输入n个点,圆的半径以及圆的坐标X,Y。
///先是判断输入的点是不是能够组成凸包(这里的判断就是所有的点是不是往同一个方向"拐")
///然后判断圆心是否在凸包内.如果在的话就判断圆心的和凸包每条边的就离是否小于R。
#include <iostream>
#include <cstdio>
#include <string.h>
#include <math.h>
#include <algorithm>
using namespace std;
const int N = 1000;
const double eps = 1e-8;
struct Point
{
double x,y;
} p
;
Point c; ///圆心
double r; ///圆的半径
int n;
/**计算叉积*/
double cross(Point a,Point b,Point c)
{
return (a.x-c.x)*(b.y-c.y)-(a.y-c.y)*(b.x-c.x);
}
/**判断叉积正负*/
int isCross(double k)
{
if(k<0) return 1;
return 0;
}
/**是否为凸包*/
bool isConvex(int n)
{
p[n++]=p[0];
p[n++]=p[1];
int dir = isCross(cross(p[1],p[2],p[0]));
for(int i=3; i<n; i++)
{
if(isCross(cross(p[i-1],p[i],p[i-2]))!=dir)
{
return false;
}
}
return true;
}
/**判断点是否在多边形内(具有普遍性,不过并不能看懂)*/ bool pointInPolygon(int n,double x,double y) { int i,j=n-1; bool oddNodes=0; for (i=0; i<n; i++) { if((p[i].y< y && p[j].y>=y|| p[j].y<y && p[i].y>=y) && (p[i].x<=x||p[j].x<=x)) { oddNodes^=(p[i].x+(y-p[i].y)/(p[j].y-p[i].y)*(p[j].x-p[i].x)<x); } j=i; } return oddNodes; }
/**判断点是否在凸多边形内(这个比较容易打并且适合这题)*/ bool pointInConvex(int n,double x,double y){ Point po; p = p[0]; po.x = x,po.y = y; bool flag = isCross(cross(p[0],p[1],po)); ///既然是判断了是凸多边形肯定相邻两个点是朝同一个方向转 for(int i=1;i<n;i++){ if(isCross(cross(p[i],p[i+1],po))!=flag){ return false; } } return true; }
///点积
double mult(Point a,Point b,Point c){
return (a.x-c.x)*(b.x-c.x)+(a.y-c.y)*(b.y-c.y);
}
///距离
double dis(Point a,Point b)
{
return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
///点c到线段ab的最短距离
double GetDist(Point a,Point b,Point c){
if(dis(a,b)<eps) return dis(b,c); ///a,b是同一个点
if(mult(b,c,a)<-eps) return dis(a,c); ///投影
if(mult(a,c,b)<-eps) return dis(b,c);
return fabs(cross(b,c,a)/dis(a,b));

}
/**判断圆是否在凸多边形内*/
bool circleInConvex(int n,double x,double y,double r){
Point po;
po.x = x,po.y = y;
p
=p[0];
for(int i=0;i<n;i++){
if(r>GetDist(p[i],p[i+1],po)){
return false;
}
}
return true;
}
int main()
{
while(scanf("%d",&n)!=EOF&&n>=3)
{
scanf("%lf%lf%lf",&r,&c.x,&c.y);
for(int i=0; i<n; i++)
{
scanf("%lf%lf",&p[i].x,&p[i].y);
}
if(!isConvex(n)) printf("HOLE IS ILL-FORMED\n");
else if(!circleInConvex(n,c.x,c.y,r)||!pointInConvex(n,c.x,c.y)){
printf("PEG WILL NOT FIT\n");
}else printf("PEG WILL FIT\n");

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: