您的位置:首页 > 其它

POJ 1840 Eqs

2016-04-27 18:40 309 查看
Language:
Default

Eqs

Time Limit: 5000MSMemory Limit: 65536K
Total Submissions: 15010Accepted: 7366
Description

Consider equations having the following form:

a1x13+ a2x23+ a3x33+ a4x43+ a5x53=0

The coefficients are given integers from the interval [-50,50].

It is consider a solution a system (x1, x2, x3, x4, x5) that verifies the equation, xi∈[-50,50], xi != 0, any i∈{1,2,3,4,5}.

Determine how many solutions satisfy the given equation.

Input

The only line of input contains the 5 coefficients a1, a2, a3, a4, a5, separated by blanks.
Output

The output will contain on the first line the number of the solutions for the given equation.
Sample Input
37 29 41 43 47

Sample Output
654

Source

Romania OI 2002
#include <cstdio>
#include <iostream>
#include <string>
#include <cstring>
#include <list>
#define MAXN 14997//一个较大的质数
using namespace std;
list<int> h[MAXN*2+1];
list<int>::iterator  it;//迭代器
int a,b,c,d,e,ans=0;
int main()
{
cin>>a>>b>>c>>d>>e;
for (int i=-50;i<=50;++i){
for (int j=-50;j<=50;++j){
if (i==0||j==0) continue;
int x;
x=d*i*i*i+e*j*j*j;
h[x%MAXN+MAXN].push_back(x);//利用链表建立哈希表,+一个质数是为了处理负数的情况
}
}
for (int i=-50;i<=50;++i)
for (int j=-50;j<=50;++j)
for (int k=-50;k<=50;++k){
if (i==0||j==0||k==0) continue;
int x;
x=-a*i*i*i-b*j*j*j-c*k*k*k;
for (it=h[x%MAXN+MAXN].begin();it!=h[x%MAXN+MAXN].end();++it)
if (*it==x)ans++;//理想状态下仅有O(1)的复杂度
}
cout<<ans<<endl;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: