您的位置:首页 > 其它

NYOJ Binary String Matching

2016-04-27 17:40 393 查看


Binary String Matching

时间限制:3000 ms | 内存限制:65535 KB
难度:3

描述Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is
‘11’, you should output 3, because the pattern A appeared at the posit

输入The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And
it is guaranteed that B is always longer than A.
输出For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.
样例输入
3
11
1001110110
101
110010010010001
1010
110100010101011


样例输出
3
0
3


来源网络
上传者naonao

/*
许久不写KMP算法了,今天恰好在nyoj上看见了,就给做了,模板题
*/
#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
const int maxn = 1005;
char T[maxn],P[15];
int f[15];

void getFail(char P[],int f[])
{
f[0] = f[1] = 0;
int len = strlen(P);
for(int i = 1; i < len; i++)
{
int j = f[i];
while(j && (P[i] != P[j])) j = f[j];
f[i+1] = P[i] == P[j] ? j+1:0;
}
}

int kmp(char T[],char P[],int f[])
{
int n = strlen(T),m = strlen(P);
getFail(P,f);
int j = 0,ans = 0;
for(int i = 0; i < n; i++)
{
while(j && P[j] != T[i])
j = f[j];
if(P[j] == T[i]) j++;
if(j == m) ans++;
}
return ans;
}

int main()
{
int n;
scanf("%d", &n);
while(n--)
{
memset(f,0,sizeof(f));
scanf("%s%s",P,T);
printf("%d\n", kmp(T,P,f));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: