您的位置:首页 > 其它

hdu 2084 数塔 dp

2016-04-27 16:26 302 查看


数塔

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 33963    Accepted Submission(s): 20257


Problem Description

在讲述DP算法的时候,一个经典的例子就是数塔问题,它是这样描述的:

有如下所示的数塔,要求从顶层走到底层,若每一步只能走到相邻的结点,则经过的结点的数字之和最大是多少?



已经告诉你了,这是个DP的题目,你能AC吗?

 

Input

输入数据首先包括一个整数C,表示测试实例的个数,每个测试实例的第一行是一个整数N(1 <= N <= 100),表示数塔的高度,接下来用N行数字表示数塔,其中第i行有个i个整数,且所有的整数均在区间[0,99]内。

 

Output

对于每个测试实例,输出可能得到的最大和,每个实例的输出占一行。

 

Sample Input

1
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

 

Sample Output

30
#include <bits/stdc++.h>
using namespace std;
int T;
int ar[101][101];
int main(){
scanf("%d",&T);
while(T--){
int h;
scanf("%d",&h);
for(int i=0;i!=h;++i){
for(int j=0;j<=i;++j){
scanf("%d",&ar[i][j]);
}
}
int depth = h - 2;
for(int i=depth;i>=0;--i){
for(int j=0;j<=i;++j){
ar[i][j] = ar[i][j]+max(ar[i+1][j],ar[i+1][j+1]);
}
}
printf("%d\n",ar[0][0]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: