您的位置:首页 > 其它

POJ3628 Bookshelf2

2016-04-27 10:43 267 查看
Bookshelf 2

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 9255Accepted: 4189
Description

Farmer John recently bought another bookshelf for the cow library, but the shelf is getting filled up quite quickly, and now the only available space is at the top.

FJ has N cows (1 ≤ N ≤ 20) each with some height of Hi (1 ≤ Hi ≤ 1,000,000 - these are very tall cows). The bookshelf has a height of B (1 ≤ B ≤ S, where S is the
sum of the heights of all cows).

To reach the top of the bookshelf, one or more of the cows can stand on top of each other in a stack, so that their total height is the sum of each of their individual heights. This total height must be no less than the height of the bookshelf in order for
the cows to reach the top.

Since a taller stack of cows than necessary can be dangerous, your job is to find the set of cows that produces a stack of the smallest height possible such that the stack can reach the bookshelf. Your program should print the minimal 'excess' height between
the optimal stack of cows and the bookshelf.

Input

* Line 1: Two space-separated integers: N and B

* Lines 2..N+1: Line i+1 contains a single integer: Hi

Output

* Line 1: A single integer representing the (non-negative) difference between the total height of the optimal set of cows and the height of the shelf.

Sample Input
5 16
3
1
3
5
6


Sample Output
1

题意:农夫约翰买了一个书架,但是书架的最高层牛们够不着,牛们就把自己像叠罗汉那样摞起来,总共有N头牛,每头牛的高度为Hi,书架高度为1<B<S,其中s为所有牛身高的和,求出,这些牛摞起来的高度和与书架的高度的差的最小值。

思路:还是01背包,每次,用不用这头牛的高度,求出所有的状态,然后从第一个开始遍历,找出最小的

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

int main()
{
int n,b;
while(scanf("%d%d",&n,&b)!=EOF)
{
int hight[20],dp[1000050];//dp为状态数组
int sum=0;
memset(hight,0,sizeof(hight));
memset(dp,0,sizeof(dp));
for(int i=0;i<n;i++)
{
scanf("%d",&hight[i]);
sum+=hight[i];
}
for(int i=0;i<n;i++)
{
for(int j=sum;j>=hight[i];j--)
{
dp[j]=max(dp[j],dp[j-hight[i]]+hight[i]);//状态转移方程
}
}
for(int i=0;i<=sum;i++)
{
if(dp[i]>=b) {printf("%d\n",dp[i]-b);break;}//找出大于b的最小值,并输出差
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: