您的位置:首页 > 其它

hdu 4707 Pet【带权并查集】

2016-04-26 19:05 344 查看


Pet

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2169    Accepted Submission(s): 1059


Problem Description

One day, Lin Ji wake up in the morning and found that his pethamster escaped. He searched in the room but didn’t find the hamster. He tried to use some cheese to trap the hamster. He put the cheese trap in his room and waited for three days. Nothing but cockroaches
was caught. He got the map of the school and foundthat there is no cyclic path and every location in the school can be reached from his room. The trap’s manual mention that the pet will always come back if it still in somewhere nearer than distance D. Your
task is to help Lin Ji to find out how many possible locations the hamster may found given the map of the school. Assume that the hamster is still hiding in somewhere in the school and distance between each adjacent locations is always one distance unit.

 

Input

The input contains multiple test cases. Thefirst line is a positive integer T (0<T<=10), the number of test cases. For each test cases, the first line has two positive integer N (0<N<=100000) and D(0<D<N), separated by a single space. N is the number of locations
in the school and D is the affective distance of the trap. The following N-1lines descripts the map, each has two integer x and y(0<=x,y<N), separated by a single space, meaning that x and y is adjacent in the map. Lin Ji’s room is always at location 0.

 

Output

For each test case, outputin a single line the number of possible locations in the school the hamster may be found.

  
Sample Input

1

10 2

0 1

0 2

0 3

1 4

1 5

2 6

3 7

4 8

6 9

Sample Output

2

Source

2013 ACM/ICPC Asia Regional Online —— Warmup

 

题目大意:给你n个点,n-1条边构建出一颗树,询问到点“0”的距离大于d的有多少个点。

思路:带权并查集,把相邻两个点直接连接,并且赋予权值为1.然后遍历一层for,如果当前节点的祖宗是0,并且权值大于d,那么计数器++。

AC代码:

#include<stdio.h>
#include<string.h>
using namespace std;
int f[100005];
int sum[100005];
int m,d;
int find(int x)
{
if(x!=f[x])
{
int pre=f[x];//pre是x的一个父节点。
f[x]=find(f[x]);//递归找祖先。
sum[x]+=sum[pre];
}
return f[x];
}
void init()
{
for(int i=1;i<m;i++)
{
f[i]=i;
sum[i]=0;
}
}
int main()
{
int t;
while(~scanf("%d",&t))
{
while(t--)
{
scanf("%d%d",&m,&d);
init();
/*
for(int i=0;i<10;i++)
{
printf("%d ",find(i));
}
printf("\n");*/
for(int i=0;i<m-1;i++)
{
int x,y;
scanf("%d%d",&x,&y);
int X=find(x);
int Y=find(y);
if(X!=Y)
{
sum[Y]=1-sum[y]+sum[x];
f[Y]=X;
}
}
int output=0;
for(int i=0;i<m;i++)find(i);
for(int i=0;i<m;i++)
{
if(sum[i]>d&&find(i)==0)
{
output++;
}
}
printf("%d\n",output);
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hdu 4707