您的位置:首页 > 其它

POJ 1862-Stripies

2016-04-26 00:00 267 查看
摘要: 对POJ 1862-Stripies的C++实现。

问题描述】
Our chemical biologists have invented a new very useful form of life called stripies (in fact, they were first called in Russian - polosatiki, but the scientists had to invent an English name to apply for an international patent). The stripies are transparent amorphous amebiform creatures that live in flat colonies in a jelly-like nutrient medium. Most of the time the stripies are moving. When two of them collide a new stripie appears instead of them. Long observations made by our scientists enabled them to establish that the weight of the new stripie isn't equal to the sum of weights of two disappeared stripies that collided; nevertheless, they soon learned that when two stripies of weights m1 and m2 collide the weight of resulting stripie equals to 2*sqrt(m1*m2). Our chemical biologists are very anxious to know to what limits can decrease the total weight of a given colony of stripies.
You are to write a program that will help them to answer this question. You may assume that 3 or more stipies never collide together.

Input

The first line of the input contains one integer N (1 <= N <= 100) - the number of stripies in a colony. Each of next N lines contains one integer ranging from 1 to 10000 - the weight of the corresponding stripie.

Output

The output must contain one line with the minimal possible total weight of colony with the accuracy of three decimal digits after the point.

Sample Input

3 72 30 50

Sample Output

120.00



【解题思路

由题可知,将各个生物重量排序后,按照从大到小的顺序进行碰撞,得出的总重量是最小的。



【具体实现

#include <iostream>
#include <ioman
3ff0
ip>
#include <algorithm>
#include <math.h>

/*最大数量*/
#define maxNum 100

using namespace std;

/*保存每个生物的重量*/
double WHT[maxNum];

/*比较大小,作为排序条件*/
bool Cmp(double a, double b){
return a<b;
}

int main(){
int num, i;

while (cin >> num && num && 1 <= num && num <= maxNum){
for (i = 0; i<num; i++)
cin>>WHT[i];

while (num>1){
sort(WHT, WHT + num, Cmp);
WHT[num - 2] = 2 * sqrt(WHT[num - 1] * WHT[num - 2]);
num--;
}
/*格式化输出*/
cout << setiosflags(ios::fixed) << setprecision(3) << WHT[0];
}

return 0;
}


【额外补充

C++的格式化输出:http://blog.csdn.net/bhbh520/article/details/1870372
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: