您的位置:首页 > 移动开发

hdu 5119 Happy Matt Friends(穷举子集类dp)

2016-04-25 23:32 369 查看
Problem Description

Matt has N friends. They are playing a game together.

Each of Matt’s friends has a magic number. In the game, Matt selects some (could be zero) of his friends. If the xor (exclusive-or) sum of the selected friends’magic numbers is no less than M , Matt wins.

Matt wants to know the number of ways to win.

Input

The first line contains only one integer T , which indicates the number of test cases.

For each test case, the first line contains two integers N, M (1 ≤ N ≤ 40, 0 ≤ M ≤ 106).

In the second line, there are N integers ki (0 ≤ ki ≤ 106), indicating the i-th friend’s magic number.

Output

For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y indicates the number of ways where Matt can win.

Sample Input

2
3 2
1 2 3
3 3
1 2 3


Sample Output

Case #1: 4
Case #2: 2
solution:
求有几个子集的异或和大于等于m,其实还是穷举子集类的dp,dp[i][j]代表前i个元素组成的子集中异或和为j的个数,状态方程 dp[i][j]+=dp[i-1][j];(不取第i个数)dp[i][j^a[i]]+=dp[i][j](取第i个数).
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn = 1e6 + 200;
int dp[45][maxn*2], n, m,a[45];
int main()
{
int t,cc=1;
scanf("%d", &t);
while (t--)
{
scanf("%d%d", &n, &m);
memset(dp, 0, sizeof(dp));
for (int i = 1; i <= n; i++)
scanf("%d", &a[i]);
dp[0][0] = 1;
for (int i = 1; i <= n; i++)
for (int j = 0; j <= 1e6; j++)
{
dp[i][j] += dp[i - 1][j];
dp[i][j^a[i]] += dp[i - 1][j];
}
long long ans = 0;
for (int i = m; i <= 1e6; i++)
ans += dp
[i];
printf("Case #%d: %I64d\n", cc++,ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: