您的位置:首页 > 其它

AYITACM2016省赛第二周(dp+其他) A-雷达装置(区间选点问题)

2016-04-25 21:50 323 查看
Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the
sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write
a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 



Figure A Sample Input of Radar Installations

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing
two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0


Sample Output

Case 1: 2
Case 2: 1


分析:

计算至少需要多少个雷达,可以覆盖这条小路,因为累的的覆盖区域是圆形,所以要想完全覆盖,就要找到内接四边形的长,半径大于长,选取合适的点!
#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;
struct S
{
double a,b;
} s[1010];
double cmp( S x,S y)
{
return x.b<y.b;
}
int main()
{
int i,n,k=1,f,v;
double j,x,y,m;
while(scanf("%d %lf",&n,&m)&&m+n)
{
f=0;
for(i=0; i<n; i++)
{
scanf("%lf%lf",&x,&y);
if(y>m||y<-m) //如果y坐标大于雷达半径,说明覆盖不到
f=1;
s[i].a=x-sqrt(m*m-y*y);//通过三角形公式转化为区间
s[i].b=x+sqrt(m*m-y*y);
}
sort(s,s+n,cmp);
v=1,j=s[0].b;
for(i=1; i<n; i++)
if(s[i].a>j) //如果左端点大于前一个的右端点,说明需要增加雷达
{
v++;
j=s[i].b;
}
if(f==1)
{
v=-1;
f=0;
}
printf("Case %d: %d\n",k++,v);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: